Xibo Player not running?


I’m new to using Xibo and we currently have it setup on Windows machines across the school but I’d like to setup the computers to run Linux instead. But I can’t seem to get the player to work without closing on itself?

Currently I’m running, Ubuntu 18.04.3 LTS and the latest build of Linux Xibo.

Welcome to the Community Matthew_DRET!

Sorry you are experiencing this issue. I would first recommend making sure that Ubuntu is up to date. After you have confirmed it id up to date, please open the Xibo Player Options application and make sure the CMS URL and Key are correct. Next can you click the Save button and confirm what message you see on screen?

Can you also try starting the Player using the Xibo Player tile rather than your Terminal to see if the result is different? If it is not, I would recommend uninstalling and reinstalling the Player again.

Many Thanks.

hello, are you running xibo player or xibo player options?
It happened to me that when I run xibo player options, it closes alone.
but when running xibo player it works without problems and I can see the content.
written with google translator

I can confirm I’m running the latest Ubuntu 18.04.3 LTS install and that all details are correct within the launcher.

Launching through the tile just opens the terminal then instantly closes it.

Tried reinstalling the Xibo client and I’m now getting this error when running it

Thank you for your reply on this and for the screenshot of the Display is active message. This is particularly unusual, I am also using Ubuntu 18.04 LTS but I cannot replicate your issue.

I would recommend uninstalling the Player at this point and reinstalling it to see if this resolves the issue. Can you also confirm that you have checked for updates and your Ubuntu install is up to date?

Also if possible are you able to record what happens when you try to start the Player using your Terminal or by clicking on the Xibo Player application tile (not the Player Options tile)?

Many Thanks.

Have you changed the Display Profile to Linux for this display?


Sorry for the long awaited reply been busy at the school.

Yes I’ve set the display to the Linux version.

I’ll try and grab a screen recording. But could it be something to do with the firewall blocking out Linux somehow? I believe considering it’s not directly connected to the domain only the ethernet connection. But then my Admin login should allow it to bypass? I’m wondering if trying a different Linux OS would be a good option as well.

Thank you for your feedback on this. It seems strange that a firewall would stop the Player application from starting correctly so I suspect this may be caused by something else.

Can you confirm if you have your CMS or any other Xibo Players installed on the same Ubuntu machine or if it just this Player and no other Players or CMS?

I can see that the Gdk::PixbufError in your screenshot has been reported to the development team for investigation. Some Users have found that uninstalling the Player, then updating Ubuntu using the
sudo apt-get update command, then reinstalling the Player has resolved the issue. Can you try the same please and run the update command and reinstall again please?

Many Thanks.

So I went to update and got a error with getting the update to download. Found out it was the smoothwall for the school blocking that and possibly Xibo.

I reinstalled Xibo and it first launched and was coming up with the splash screen then after about a minute the player closed and now when I’m opening the player it’s just instantly closing again? Strange I don’t know if to try taking the player home and trying it away from the network?

Also the Xibo CMS is currently running off of a Windows server within the school and I can confirm that 4 Windows players work correctly on it. I’m starting to think that smoothwall may still be playing issues as it’s not in Active Directory on the main server so it’s not exactly on the domain?


I had a similar problem where the player would immediately shutdown before displaying anything. it didn’t like something about one of the layouts I was displaying but crashed without an error before it could download a new scheduled layout.

I resolved it by scheduling a basic layout for that display , a static picture, . going into my local library folder on my linux player and deleting any .xlf files I could find and then launching the client, which would then force a client download.

my local library folder was /home/xibo/snap/xibo-player/common/resources the folder under home will change depending on the name of the user you are using to run the linux xibo client.

i’ll log specifics of the problem with my layout in a seperate forum post.

Hope the above helps.

Bullfrog (Jeremy)

Thank you for the update on the situation and for confirming that the Player is still occurring after the first boot. I like the advice of JezzatheBullfrog (I like the name by the way :slight_smile: )and agree that it’s a good idea to make sure the Layout that is set as Default and/or scheduled on your Display should be very simple in design to ensure that this is not the cause of the immediate close.

If you do decide to try the Player at home then I would also be interested to know if the issue persists but it should not be the connection that stops the Player from opening. It would still be an interesting test to find out if that is indeed the case.

Many Thanks.


So I set a default layout onto the Linux player and deleted the resources folder which had all the files downloaded from the previous layout. (This new layout is just a still image) Now I get a new error which will pop up the first time then close the player, I’ll open it again to getting no error and instead the player just instantly closes again.


Thank you for the update, I’m not sure that deleting the resources folder was a good idea. Has the resources folder returned?

Could you instead try removing the scheduled Event for the Layout in your CMS and instead setting a very simple Layout. Next reinstall the Player but this time try setting the Local Library to a location that is not within the xibo-player directory, perhaps instead try the Documents directory.

Many Thanks.