Xibo not displaying portrait layout


We are using Xibo 1.8. Our PC was originally displaying a landscape layout, however we changed the PC orientation and then assigned a portrait layout. Xibo is not registering the PC’s orientation and is only displaying in the top right hand side. This is not an issue with starting Xibo before we have changed orientation. We have also restarted the PC and Xibo whilst the PC has been in portrait with no success…Please help!!

So to display portrait layouts correctly you need:

  • Portrait layout :slight_smile: - done
  • Portrait orientation on the device - done
  • Portrait display profile assigned to your device - to do

Display settings page → edit(or create new) display profile → location tab → enter width/height
for example:

Make sure your device has the portrait display profile assigned to it, restart you device and it should work just fine.

Hi Peter, I followed your instructions however it is still showing as landscape in the corner of the screen. What are the portrait display profile settings on the device? We have not had to change settings for this to work before.

Thanks, C

Does your device has now the portrait display profile assigned to it?
Did you restart your player?

Hi Peter,

If you mean, is the PC set in portrait, then yes. We have also restarted the player.

I meant display profile ie
Create new portrait display profile on Display settings page in CMS
assign this profile to your display device on Displays page -> edit display -> advanced tab

Edit, although if you set the portrait orientation in Windows, then, if display profile is as default ( 0 and 0 in dimensions - ie full screen) it should be displayed correctly as well.

I’ve just checked that with 1.8 beta CMS and 1.8 Xibo for Windows and it does work just fine here.

Thanks great thanks, changed the setting to 0 and 0.