Xibo Docker upgrade problem


#1

Centos 7 with docker and compose from docker website.

Installed docker version of 1.8.9. It is working.

Now I am trying to upgrade to 1.8.10. Tried the doc method and after upgrade it just does not work. Lucky I was using KVM and made a backup of the whole KVM.

This is the first time I am using docker so most likely the problem is my side.
So what I did for testing was the following steps. This is without any upgrading of compose files. Just testing.
docker-compose stop
then docker-compose down
then docker-compose up -d

Just doing these commands I could not get the xibo up again.
What am I doing wrong?

P.V.Anthony


#2

I will need some more information, so I can look into this further:

What is happening when you run the docker-compose commands?
Are you running the docker-compose commands from the Xibo directory you created?
Are you receiving errors?

I would first recommend running docker-compose up, without -d, so that you can see the log output in your console. Once you have done this, please let me know what messages/errors you receive. I would also recommend using the docker-compose start command instead of up, to see if this resolves the issue.

Many Thanks.


#3

No error.

Please note I was successful when installing the docker version of xibo 1.8.9 and it is running fine. Now I want to upgrade the docker version of xibo to 1.8.10. Using Centos 7 with docker rpm from docker website. Not using Centos Docker.

Here are the output from the commands.

cd /opt/Xibo/xibo-docker-1.8.9/

docker-compose stop

Stopping xibo-docker-189_cms-web_1 … done
Stopping xibo-docker-189_cms-xmr_1 … done
Stopping xibo-docker-189_cms-db_1 … done

No error. Checked the xibo login and it is not working. So it did stop.

Next tried the following command.

docker-compose start

Starting cms-db … done
Starting cms-xmr … done
Starting cms-web … done

No error. Checked the xibo login and it is working. So it did start and working. Good.

Did a docker-compose stop again. Then did the following command.

docker-compose down

Removing xibo-docker-189_cms-web_1 … done
Removing xibo-docker-189_cms-xmr_1 … done
Removing xibo-docker-189_cms-db_1 … done
Removing network xibo-docker-189_default

Then did the following without any new files. Just do the up after the down. Just to see if it works.

docker-compose up

Creating network “xibo-docker-189_default” with the default driver
Creating xibo-docker-189_cms-xmr_1 … done
Creating xibo-docker-189_cms-db_1 … done
Creating xibo-docker-189_cms-web_1 … done
Attaching to xibo-docker-189_cms-db_1, xibo-docker-189_cms-xmr_1, xibo-docker-189_cms-web_1
cms-db_1 | 2018-08-17 17:39:39 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
cms-db_1 | 2018-08-17 17:39:39 0 [Note] mysqld (mysqld 5.6.40) starting as process 1 …
cms-db_1 | 2018-08-17 17:39:39 1 [Note] Plugin ‘FEDERATED’ is disabled.
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Using atomics to ref count buffer pool pages
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: The InnoDB memory heap is disabled
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Memory barrier is not used
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Compressed tables use zlib 1.2.3
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Using Linux native AIO
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Not using CPU crc32 instructions
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Initializing buffer pool, size = 128.0M
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Completed initialization of buffer pool
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Highest supported file format is Barracuda.
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: 128 rollback segment(s) are active.
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: Waiting for purge to start
cms-db_1 | 2018-08-17 17:39:39 1 [Note] InnoDB: 5.6.40 started; log sequence number 131194322
cms-db_1 | 2018-08-17 17:39:39 1 [Note] Server hostname (bind-address): ‘*’; port: 3306
cms-db_1 | 2018-08-17 17:39:39 1 [Note] IPv6 is available.
cms-db_1 | 2018-08-17 17:39:39 1 [Note] - ‘::’ resolves to ‘::’;
cms-db_1 | 2018-08-17 17:39:39 1 [Note] Server socket created on IP: ‘::’.
cms-db_1 | 2018-08-17 17:39:39 1 [Warning] Insecure configuration for --pid-file: Location ‘/var/run/mysqld’ in the path is accessible to all OS users. Consider choosing a different directory.
cms-db_1 | 2018-08-17 17:39:39 1 [Warning] ‘proxies_priv’ entry ‘@ root@075037e44c00’ ignored in --skip-name-resolve mode.
cms-db_1 | 2018-08-17 17:39:39 1 [Note] Event Scheduler: Loaded 0 events
cms-db_1 | 2018-08-17 17:39:39 1 [Note] mysqld: ready for connections.
cms-db_1 | Version: ‘5.6.40’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 MySQL Community Server (GPL)
cms-web_1 | Waiting for MySQL to start - max 300 seconds
cms-web_1 | MySQL started
cms-web_1 | DBVersion
cms-web_1 | 140
cms-web_1 | Existing Database, checking if we need to upgrade it
cms-web_1 | Updating settings.php
cms-web_1 | Configuring Maintenance

Tried going to the xibo login page but login page does not appear. Need advise. Please continue to help.

Yes.

No, from the looks of the returns mentioned above.

I did a start command without changing any files and it did work. This is before doing the down command.
Once the down command has been used, the start command still does not work. And there is no error for the start command.

I wonder what I have missed. Please advice.

P.V.Anthony


#4

Thank you for your answering my questions and including the log information.

According to those logs, it appears the docker-compose up command may be getting stuck at the Configuring Maintenance step. This can be caused by incorrect XMR settings. It may also be that it needs a little more time to finish configuring. Can you confirm how long it is hanging on this step for and whether you are having to force the script to stop?

I have included below a link to the Post Installation Guide, which includes a section on how to configure your XMR Public address.

In case you are unable to access the CMS to change the XMR address, I have included a link below to a guide that explains how to run sql commands when using Docker.

Once you have followed the above instructions, you can use the below statement to change the XMR Public Address:

UPDATE `setting` SET `value` = 'tcp://yourIPorDomain:9505' WHERE `setting` = 'XMR_PUB_ADDRESS';

You can also use the below statement to confirm the settings have changed:

SELECT * FROM `setting` WHERE `setting` = 'XMR_PUB_ADDRESS' ;

If the issue persists, please let me know.

Many Thanks.


#5

The XMR setting is “tcp://192.168.1.203:9505”. It is the ip of the xibo server itself. I am able to ping it as well.

Yes I had to force the script to stop after 10 minutes of waiting. Do I have to wait longer?

Here is the firewall settings done.
[root@xibo ~]# firewall-cmd --zone=public --add-port=9505/tcp --permanent
success
[root@xibo ~]# firewall-cmd --zone=public --add-port=80/tcp --permanent
success
[root@xibo ~]# firewall-cmd --zone=public --add-port=443/tcp --permanent
success
[root@xibo ~]# firewall-cmd --reload

Whatelse can I do? please note this is centos 7 with the docker from Docker website.

Could it be the firewall setting?

P.V.Anthony


#6

Any advice on how to move forward?
I need all the help I can get.

P.V.Anthony


#7

My apologies for the late reply. Based on the information you have given, it would seem that the configuring maintenance stage of the up command is taking some time. I would recommend running docker-compose up -d, and giving the container some time to finish this stage. If the issue persists and you are unable to access your CMS, you may need to look again at your setup, as the issue may not be with Xibo.

Many Thanks.