Xibo Docker Upgrade makes fresh and clean install :(

Hello community,
I’m trying to upgrade my Xibo Docker.
Version 4.05 used. So far it has always worked with the following commands.


I dosn’t use SSL, also i make the follow commands in the Shell:

Run these as the root user:

Stop the running container

cd /opt/xibo
docker-compose stop

Backup the existing container data

cd /opt

Delete any old backup version

rm -r xibo-backup
cp -rp xibo xibo-backup

Download the new docker-compose files

cd /opt/xibo
wget -O xibo-docker.tar.gz https://xibo.org.uk/api/downloads/cms
tar --strip-components=1 -zxvf xibo-docker.tar.gz

#Startup Xibo (Upgrade completed)
docker-compose up -d

But now the new version is installed, but completely as a fresh installation. Standard Admin is active again and my layouts are gone.

What’s different… do I need to do something different. I don’t understand why it’s no longer possible to upgrade with the commands from version 4.05 onwards??

The only thing that is different is that I now run Xibo Docker on an ESXi in an Ubuntu VM. Previously I had a hardware machine running Ubuntu.
But I don’t think it has anything to do with it. Current OS Ubuntu 22.04 “Jammy Jellyfish”.

Many Thanks for answer.

Kind regards Mario from Germany

I believe you want to do

docker-compose down

Make a backup of that directory

Edit the appropriate files you downloaded to fit your needs and move them into your existing xibo directory.

Then from your existing directory

docker-compose -f (custom file name) up -d

If you follow this link you really can’t go wrong. They’ve spelled it out perfectly

Hi Jon,

i make the upgrade step by step from the manual UPGRADING from here (Xibo CMS with Docker on Ubuntu 22.04) there is my shell:

lcadm@MIRACULIX:~$ cd /opt/xibo
lcadm@MIRACULIX:/opt/xibo$ sudo rm xibo-docker.tar.gz
[sudo] Passwort für lcadm:
lcadm@MIRACULIX:/opt/xibo$ ls
cms_custom-ports.yml.template config.env.template LICENSE
cms_remote-mysql.yml config.env.template-remote-mysql README.md
config.env docker-compose.yml
lcadm@MIRACULIX:/opt/xibo$ sudo docker-compose stop
Stopping xibo_cms-web_1 … done
Stopping xibo_cms-quickchart_1 … done
Stopping xibo_cms-db_1 … done
Stopping xibo_cms-xmr_1 … done
Stopping xibo_cms-memcached_1 … done
lcadm@MIRACULIX:/opt/xibo$ cd /opt
lcadm@MIRACULIX:/opt$ ls
containerd lampp xibo
lcadm@MIRACULIX:/opt$ cp -rp xibo xibo-backup
lcadm@MIRACULIX:/opt$ sudo cp -rp xibo xibo-backup
lcadm@MIRACULIX:/opt$ ls
containerd lampp xibo xibo-backup
lcadm@MIRACULIX:/opt$ cd /opt/xibo
lcadm@MIRACULIX:/opt/xibo$ sudo wget -O xibo-docker.tar.gz https://xibosignage.com/api/downloads/cms

xibo-docker.tar.gz 100%[===================>] 15,68K --.-KB/s in 0,002s

2024-04-30 15:11:44 (9,07 MB/s) - ‘xibo-docker.tar.gz’ gespeichert [16054/16054]

lcadm@MIRACULIX:/opt/xibo$ sudo tar --strip-components=1 -zxvf xibo-docker.tar.gz
lcadm@MIRACULIX:/opt/xibo$ sudo docker-compose pull
Pulling cms-db … done
Pulling cms-xmr … done
Pulling cms-web … done
Pulling cms-memcached … done
Pulling cms-quickchart … done
lcadm@MIRACULIX:/opt/xibo$ sudo docker-compose up -d
Recreating xibo_cms-memcached_1 … done
Recreating xibo_cms-web_1 … done
Recreating xibo_cms-db_1 … done
Starting xibo_cms-quickchart_1 … done
Recreating xibo_cms-xmr_1 … done

Upgrade end, Version is the newest Version 4.0.10 , but Login is Standard Xibo , all Layouts are gone, it is only a fresh install but no upgrade.
What can i do, have i forget any tag ??

Thanks kind regards Mario

From what I can see and I may be wrong so my apologies if that’s the case, but you shouldn’t be doing docker-compose pull. By pulling you’re essentially creating an entire new instance , which I believe is the results you’re seeing .

I don’t even see that command on the instructions you posted.

Xibo recommends doing it as root also

Hello Jon,
the command docker-compose pull cames befor docker-compose up -d it`s all in my Shell and as root user.

Kind regards…

I just installed version 4.0 in docker / Ubuntu for testing and all you do is download the tar file, unzip then make your edits (if you want). As root.


docker-compose -f cms_custom-ports.yml up -d

Does it’s stuff

Login, Change xibo_admin password, make a layout, uploaded 20 videos, make playlist, connect player, add schedule , wait for player to playback

Back to shell.

docker compose down

Tar my directory xibo.tar.gz

scp to a file server copy my backup

Move to



tar xvf 573

Does it’s stuff

Cd to new directory /home/kashikoi/xibo-docker-4.0.10/

Modify the cms_custom-ports.yml.template file to my needs reflecting the changes I’ve made and save to


Cd home/kashikoi/xibo

docker-compose -f cms_custom-ports.ymp up -d

Old data is still in tact. I tried this with version 4 to 4.0.1 to 4.0.8 then finally 4.0.10

You don’t need to do docker pull as docker-compose does all the work.

Just follow exactly the directions you pasted the link to, which is all I’ve done. So your either doing it in another directory (new install) or your over thinking things.

Just for fun, word for word paste their instructions. It’s almost impossible to botch

Hello Jon,

sorry but it’s crazy but absolutely my mistake.
On the hardware machine I always had /opt/XIBO as the path. On the virtual machine I used /usr/XIBO as the path for whatever reason. But that was just it. When you wrote or did you create it in a new path, I checked the paths and found exactly that :frowning: . With the correct path everything works as before, really stupid of me. I still hope that someone has the post It’s also useful to others, even if it’s a wink to his own stupidity :slight_smile:
Thanks Jon for your help.

It’s never stupid man! That’s what these kind of forums are for. Glad it worked out for you!