Xibo docker on Ubuntu server 18.03


I followed all the steps in the forum but when i do docker-compose up -d the i Will het the following error:

/usr/local/bin/docker-compose: Line 1: Not: command not found

Who dan help me ?? Im doing something wrong


Have you Installed Docker on your ubuntu ?

Best Regards,

Joshua Kaczmarek.


Docker is installed. If i run docker-compose up it will throw a error:

Can’t find a suitable configuration file in this directory or any parent. Are you in the right directory?

Supported filenames: docker-compose.yml, docker-compose.yaml

When i run docker-compose --version it gives the version that is installed.

i don’t know what to do now.

1 Like

Maybe you should create the file “config.env”, a copy of the “config.env.template” file.

Put inside it a password for your SQL Database, and try again.



if i look in my config.env the password is there. But when i run docker-compose up -d i get
/usr/local/bin/docker-compose: line 1: syntax error near unexpected token '<'usr/local/bin/docker-compose: line 1: 'Malformed request

I think you have a problem with docker.

Try to uninstall it and then do all these commands in terminal :

sudo apt-get update
sudo apt-get install apt-transport-https ca-certificates curl gnupg-agent software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88
sudo add-apt-repository \ “deb [arch=amd64] Index of linux/ubuntu/ \ $(lsb_release -cs) \ stable”
sudo apt-get update
sudo apt-get install docker-ce docker-ce-cli containerd.io
sudo docker run hello-world

Paste me the answer of the last command.

tnx for your help :slight_smile: but i get the following answer when i do run hello-world:

That’s the right answer !

Try again to launch Xibo Docker and tell me what’s happening.

(Use cd to go in the repertory where Xibo Docker is)



If i do that i get the following error:

That’s Weird.

I’m sorry but i can’t help more than this for now… Try too search this error message on google and you should find a soluce to this problem. I don’t think this is linked with Xibo.

(if you find it, put the soluce here and set the topic on solved)



I’m already searching for this problem. But there is no answer to this problem. If i found the solution i will posted it here.

Thnx for your help. I’ll hope someone has the answer

have you tried this :

sudo curl -L “https://github.com/docker/compose/releases/download/1.22.0/docker-compose-$(uname -s)-$(uname -m)” -o /usr/local/bin/docker-compose
sudo mv /usr/local/bin/docker-compose /usr/bin/docker-compose
sudo chmod +x /usr/bin/docker-compose

Oh and your folder need to have all rights :

sudo -s
/opt chmod 777 xibo
/opt/xibo chmod 777 xibo-docker-“yourversion”

Try this :smiley:

You did not downloaded compose file, but html file. Redownload as @joshkacz instructed you

1 Like


When i want to redownload docker-compose with the code @joshkacz give here all i get is the HTML file.

I think i do something wrong buy cant find out what it is

You started docker-compose from /usr/ bin. Probably this is also a faulty file from one of your previous attempts. Please delete this and any other first

sudo rm /usr/bin/docker-compose /usr/local/bin/docker-compose

I recommend a completely new attempt of installation. Get permanent root rights for your session

sudo -i

Remove all previosly installed docker or docker-ce packages

apt purge docker docker-ce

And follow exactly the install guide which works under Ubuntu 18.03 too

I already tried a new installation 3 times but everytime i only get the a help file with this code:

add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable"

If i use the following code:

add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable"

it will down another file

How is this possible? I will do another attempt to install it on the way in the install guide.

please provide the output of the add-apt-repository command


Here is the output of the command:

I just reinstalled the whole os Ubuntu server 18.04. I followed the guide to install xibo on docker but when i do docker-compose up -d it will trow the error i posted earlier.

I don’t know what i need to do to get this working

i ran this command to install docker-compose:

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

instead of this:

sudo curl -L https://github.com/docker/compose/releases/download/1.24.1/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose

and now it is working :slight_smile: