Xibo Docker 1.8.11 large file uploads fail with "internal server error"

Hey, I have the following problem in the latest version. When I try to upload a file, for example 400MB, I just get “internal server error”. 400MB should be well under the 2GB limit, and the logs doesn’t show any information about the upload. Can somebody help me?

If you can also provide a screenshot of the full error and more information about the file you are trying to upload, for example what type of file it is and whether you have been able to successfully upload a file of similar size and/or format previously.

If you have not already done so, please select the Report Fault option in your CMS. Follow the instructions on screen and choose Turn on Debugging when the option is presented. Clicking next will then take you to the Recreate the Problem Page. Click the Open a New Window button, attempt to upload the file again and then return to the original window where you started the Report Fault service and select Collect and Save Data.

Following the above instructions will provide you with a troubleshoot.zip file. You are welcome to use the below link to upload the troubleshoot zip file so I can take a closer look.


Please note that you will need to private message me the URL you are given once you have uploaded the zip folder.

Many Thanks.

Users tried to upload a video with around ~250MB, which didn’t work. In this case im uploading a nice little pdf-File for testing with around 490MB. Before switching to docker we could upload things that size without any problems.
I’ve send you a pm with the troubleshoot.zip, although I couldn’t find anything useful in the log.

1 Like

I am experiencing this same issue. My MPEG-4 is 15.2 MB its gets to 100% upload and then gives this internal server error.


Thank you for the download link, I will test the file. Are you also running a Docker 1.8.11 installation? What is the OS it is running on?

Many Thanks.

This was with my mac. I finally manually renamed the file to .mp4 and uploaded it to media instead this worked for me. it wouldnt accept the other formats I tried