XIBO CMS - Curl error 28 timeout on API /JSON Remote Dataset


We’re unable to fetch data via curl command from a xibo cms to a web server. The command line “curl https://apitest.xxxxxxxx-xxxxxxx.fr:15657/api/Dossier/Requete PersoTexte?requete=XB_DATEHEURE” therefore does not work on the CMS but does return data from the Linux hosting the CMS as well than from any other PC or Windows Server on our network.

Here some pictures to illustrate :

We have installed Wiresharlk (TcpDump) on the web server delivering the request data, we can see the frames when they are launched from an OS or a browser but there is nothing from the test command on the XIBO CMS .

Could you help us understand how to make XIBO communicate with another server to retrieve data (JSON in our case on an IIS Windows server) thank you.

Xibo 3.3.1/Ubuntu 20.04 <—> IIS Server 10.0.17763.1 - Windows 2019 Server Standard

Have you confirmed connectivity between the machine you’ve installed Xibo on (Ubuntu 20.04) and the URL you’re trying to request?

curl -v https://apitest....<the url>

Typically the cURL error you’re getting is pushed up from cURL installed on the operating system.

Hello Dan,

I tried to curl via ssh on Ubuntu 20.04, the result is correct and passes without problem.

As I told you, the frame analysis on the server that delivers the results indicates network packets when the curl is performed via a browser, in “cmd” on windows or on the Ubuntu host of Xibo.

I therefore consider that there is a probable misconfiguration or a bug and I cannot find what it is.

Thanks for your help.

Hmm, that is strange!

This is probably a silly question, but does it return in under 5 seconds on the command line?

Also how is your CMS installed? Via Docker or directly on the host?


The result is displayed instantly via CLI (SSh on Xibo Host or other SSH) or https from my laptop, other laptops/servers.

What is absolutely surprising is that nothing leaves from the CMS by clicking on the page in question in XIBO since my “Wireshark” (frame analyzer) gives me the technical network information (packets) when I use the CLI or https , but there are absolutely no packets from XIBO CMS.

The CMS is installed on Ubuntu 20.04 Linux host with Apache, Mysql and everything in the installation documentation.

I don’t know how to “buy” maintenance to involve an expert technician because here I admit that apart from intervening on our infrastructure, it may be complicated to solve I think.

Thank you and see you soon.

That is indeed rather odd!

Can you check your “Administration → Settings → Network” to make sure you don’t have a proxy configured?

Failing that, can you follow the “Report Fault” process and PM me the resulting file - don’t post it here as there will be sensitive info inside.

Unfortunately we cannot offer paid support on non-docker installations, there is just so much out of our control in that scenario it is impossible to fairly charge for it. FYI our supported environments are here.


Oh my god, it was exactly that problem!

Thank you because I was starting to go crazy, we are 4 working on this project and I am the only one to take care of the sysadmin part, the internal configuration was carried out by a colleague, he owes us at least 1 good coffee!

A very big thank you !

1 Like

You’re very welcome!! I am pleased that solved the issue for you.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.