Xibo CMS 1.8 - Add Region

No region can be added with the “de” regional setting. The URL is: http://www.xxxxxxxxxx.com/xibo-cms-1.8.0/web/region/2
Error message: page not found

With “en_GB” it works. The URL is: http://www.xxxxxxxxxx.com/xibo-cms-1.8.0/web/layout/designer/2

Best regards


I see the same issue here. I’ll create a bug for it.

As an aside, your CMS is incorrectly installed.

With Xibo 1.8, only the “web” folder should be available to be served by the webserver. The rest of the code isn’t supposed to be accessible.

Our strong recommendation is to use Docker for 1.8 installs.

Thank you for your report.

Hi Alex,

How can I check if the web server configuration is OK ?

Thanks in advance


Currently, your webserver exports a directory as it’s “web root”.

Inside that, you’ve got a directory xibo-cms-1.8.0 and inside that web.

What you need to do, is configure the web directory inside xibo-cms-1.8.0 to be your web root. Nothing above “web” should be accessible to the Internet.

Alternatively, you can extract xibo-cms-1.8.0 elsewhere, and then make a symlink between a folder called say xibo inside your existing webroot, and the web folder wherever you’ve put that.

From 1.8 onwards, the only offical method we support for the CMS is Docker based installs. It means that everyone has the same environment, so we don’t have these kinds of issues.

You may continue to run Xibo in a “custom” install at your option, but we won’t necessarily be able to offer you support for it going forward.

Docker is not possible. Windows Server 2008 running in virtual machine.
Have it solved now via Alias entry.

Alias created:

directory "C:\hosting\xibo-cms-1.8.0\web"
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Allow from all
Require all granted

Alias /xibo-cms-1.8.0 “C:\hosting\xibo-cms-1.8.0\web”

.htaccess in “web” Directory:

RewriteEngine On

RewriteBase /xibo-cms-1.8.0

fix authorization header

RewriteCond %{HTTP:Authorization} .+
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

requests for api authorize

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^./authorize/.$
RewriteRule ^ api/authorize/index.php [QSA,L]

requests that start with api go down to api/index.php

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^./api/.$
RewriteRule ^ api/index.php [QSA,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^./install/.$
RewriteRule ^ install/index.php [QSA,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^./maint/.$
RewriteRule ^ maint/index.php [QSA,L]

all others - i.e. web

RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [QSA,L]

I think this is ok now.

And thanks for the help.

1 Like