Xibo Client unable to display embedded IpCam streaming

I have a TP-Link Ipcam and can be accessed via Windows browser at (I use LAN server). In Xibo server, I can also access such IPcam video streaming. The video is displayed automatically when I add embedded module with iframe code. However in Xibo Player (Xibo Server and Xibo Client/Player are at the same computer), I got white blank screen

I also tried with Webpage module, but with the same result. Could you tell me what is the problem and how to solve?

You may get it working by updating the version of Internet Explorer used by the Xibo Player:

However some cams use plugins or scripting that won’t work when run from a local webpage (due to security considerations within Internet Explorer) and those just don’t work.

If you were running Android Players, and the webcam outputs an RTSP stream then you could show the stream directly like this:

When you open the link in computer, What browser use you?

Enviado do meu iPhone

@alex, I tried xibo at my office. I will try it when I am at my office. I used Xibo 1.71 and the latest one (1.74), but with the same result.
@thiago, I mostly use Firefox. But for that case, I have tried IE (default, WIndows 7), and both work well in accessing Ipcam’s video streaming. To manage XIbo server, I use Firefox (IpCam’s video stream is displayed automatically in a designated region)…

  • I have tried the suggestion of adding a registry key, but it still doesn’t work. Later, I found the problem is in the security issue of IE 11 (default IE in my Win7). The new IE does not allow http://username:password@ Sorry, my previous post doesn’t mention username:password@ for automatic login in IPCam (in my case, http://admin:admin@ If I remove username:password@ or admin:admin@ in Xibo Embeded module, the IPCam video streaming is displayed in Xibo Client/Player but I was prompted with login information first. This is annoying.
  • I read that the newest IE has disabled username:paswsword@ function in HTTP/HTTPS/URL. So I tried the following steps to disable to enable it: (1) Open RegEdit (Start→Run→”regedit”), (2) Navigate to [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_USERNAME_PASSWORD_DISABLE]. (3) Create two new REG_DWORD values, set to 0, named “iexplore.exe” and “explorer.exe” (4) Reboot. Unfortunately, with no luck. I read one post, attempt to enable it in IE 9 is also with no luck.
  • Sorry for mistype… what I mean “…the following steps to enable it.”
  • I found a solution to display without login in XiboPlayer. In TP-Link IPCam, in Security-Account, there are three categories of Viewer authentification: Admin, Operator, and Viewer. I set Off to Viewer. Now, it works. Thank you for a clue or a starting point in an attempt to find a solution.

Your key there would need to be for XiboClient.exe not for explorer.exe or iexplore.exe

It’s the name of the application embedding the .net control that is required, not the name of the browser itself.

I’m glad you have it working by another means though.

TP-Link IPCam uses IE as its default browser, so I thought iit should be applied to iexplorer.exe or explore.exe :smile: . I will try the other option (your suggestion) later.