Xibo Client not showing campaign

Hello there !

After many struggles I finally finished my campaigns and it looks good. But the problem is that I can’t manage to have it on my display.
After installing the Xibo Client on the computer that will be used to be duplicate on a TV (the same I have my localhost xibo) it worked fine. The display is recognized ans authorized but when I launch the Xibo Player, the default layout I have selected (which is the logo of the company) is repeating constantly, without ever showing my campaign, composed of 7 different layouts.

I have tried to plan the campaign to repeat for hours, months, even years, but nothing’s changed, I still end up with my default logo showing.

Can somebody tell me why ?

Thanks in advance !!


Did you schedule the campaign to show on the display?

Yes, I selected my display when I planned the campaign.

On the displays page - has the display got a “tick” next to its status? If not, what does it have?

No it has an exclamation point…
When I override it it says “Display is out of date but has not yet checked in with the server”

So it seems that either your device has some connections problems and can’t reach CMS for the updated schedule/content or that scheduled content is invalid.

What’s your collection interval and download window start/end time settings?
(you can see it in display settings page, edit display profile that your device is using)

If you’d try to create simple valid layout and ‘schedule now’ it on your player, would that work?

If you could also open status window on your device press ‘i’ while player is running and take a screenshot of it that could help us determine what could be wrong.

Side note: both CMS and player are in 1.7.5 version, correct?

I’ve put the collection interval at 60 seconds for testing purpose.
The thing is, that yesterday it started working, out of nowhere but now, I’m faced with the same problem, again…

I’ve tried created a test layout, but the default layout selected for the display if there’s a problem, keeps showing…

There is nothing showing when I press i. The window opens but there is no informations…

The CMS is in 1.7.4 version… I’m not sure for the player, how could I confirme that ?

Run Xibo Player Options(where you specify the CMS address and key), on toolbar Help->About

So, basically, when there is nothing scheduled(or schedule is invalid) your device will display default layout.
If default layout is invalid then it will display splash screen.

Just to confirm your Download Window start/end time are set to 00:00:00? (which means it’s always open)

If your device is displaying your default layout (assuming nothing else is scheduled) and you schedule simple test layout that for sure is valid (checkmark in CMS) then after 60s your player should know about this schedule and download necessary files then display your test layout.

Perhaps your default layout has a really long durations? Which can cause the scheduled layout to be ‘missed’.

Please see this topic about Durations and this article Scheduled Layouts not working

Check time and date on the client, is it matching with server date/time . Check the status on client side.

The version of the Xibo player is 1.7.0-rc1

Yes, the Download window start/end time are set to 00:00.
I don’t think it comes from that, because the default layout is 10 seconds long and the others are at least 20 seconds long…

What really is weird is that it will sometimes start to work… and then when I start it on my own it won’t work…
Also, if it’s working, I’l have a message error when the forecast layout is up. It puts this big red cross across the layout and a .NET Framework window pops up saying that I have an “unhandled exception”, is there an explanation to that ?

Thanks again for all the help !