Xibo Client download faled

I’m using xibo client on Windows 10 Environment. First I have set up the client to CMS. And in display list my client listed. After that, I’m design on default layout and assign to display. Furthermore, the client doesn’t show any video. Is there anything miss?

In media → manage, I see there many pending for this devices. I’ve tried to run as administrator and doesn’t seems work for me. Here my screenshot for detailing this issue

Assign to Display is not what you need to use. Assign simply causes the Player to download the layout. It won’t then show it.

If you want the Player to show content, you need to use the Schedule to say when it should start and stop showing it. When you do that, the layout will be downloaded and shown automatically.

Assign is there for very specific use cases involving the API.

The Player doesn’t need to run as an administrator. It’s hard to say without seeing it what is going on, but from your screenshots it looks as if the Player isn’t able to download anything. That might be because the storage location you’ve chosen for the Player isn’t writeable? Did you change it from the default?

Otherwise it might be a configuration issue with your CMS. How did you install it?


The player storage location is on default location. There is on C:\Users\root\Documents\Xibo Library.
I check for php.ini that I don’t load module zeromq. This module cause this problem?


That’s unlikely to be the cause.

Does the Player download anything from the CMS?

Is the CMS on the same computer, or a remote one?

I’ve checked from documents directory and only found folder background with empty file inside. See my screenshot bellow

The CMS and the client is on different computer and working with windows 10 machine x64. Is it zeromq is the problem? obviously zeromq not yet installed side a side with PHP and apache.

Any idea alex?

ZeroMQ missing won’t cause the Player not to download content.

Clearly it hasn’t been able to, nor has it been able to upload any logs as those are all queued there too.

If you open the Player settings and save, what message is shown in the log window?

Alex, here are the message that shown on log windows on the player options

Client found response content type of 'text/html; charset=UTF-8', but expected 'text/xml'.
The request failed with the error message:
<br />
<b>Deprecated</b>:  Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in <b>Unknown</b> on line <b>0</b><br />
<br />
<b>Warning</b>:  Cannot modify header information - headers already sent in <b>Unknown</b> on line <b>0</b><br />
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:xmds" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:RegisterDisplayResponse><ActivationMessage xsi:type="xsd:string"><?xml version="1.0"?>
<display date="2017-12-14 17:38:14" timezone="UTC" status="0" code="READY" message="Display is active and ready to start." version_instructions="{&quot;id&quot;:8,&quot;file&quot;:&quot;8.otf&quot;}"><CollectInterval type="int">900</CollectInterval><DownloadStartWindow type="string">00:00</DownloadStartWindow><DownloadEndWindow type="string">00:00</DownloadEndWindow><PowerpointEnabled type="checkbox">0</PowerpointEnabled><StatsEnabled type="checkbox">0</StatsEnabled><XmrNetworkAddress type="string"/><SizeX type="double">0</SizeX><SizeY type="double">0</SizeY><OffsetX type="double">0</OffsetX><OffsetY type="double">0</OffsetY><ClientInfomationCtrlKey type="checkbox">0</ClientInfomationCtrlKey><ClientInformationKeyCode type="string">I</ClientInformationKeyCode><LogLevel type="string">error</LogLevel><LogToDiskLocation type="string"/><ShowInTaskbar type="checkbox">1</ShowInTaskbar><CursorStartPosition type="string">Bottom Right</CursorStartPosition><DoubleBuffering type="checkbox">1</DoubleBuffering><EmptyLayoutDuration type="int">10</EmptyLayoutDuration><EnableMouse type="checkbox">0</EnableMouse><EnableShellCommands type="checkbox">0</EnableShellCommands><ExpireModifiedLayouts type="checkbox">1</ExpireModifiedLayouts><MaxConcurrentDownloads type="int">2</MaxConcurrentDownloads><ShellCommandAllowList type="string"/><UseCefWebBrowser type="checkbox">0</UseCefWebBrowser><SendCurrentLayoutAsStatusUpdate type="checkbox">0</SendCurrentLayoutAsStatusUpdate><ScreenShotRequestInterval type="int">0</ScreenShotRequestInterval><ScreenShotSize type="int">200</ScreenShotSize><MaxLogFileUploads type="int">3</MaxLogFileUploads><EmbeddedServerPort type="int">9696</EmbeddedServerPort><PreventSleep type="checkbox">1</PreventSleep><DisplayName type="string">ITEN-EXPLORER</DisplayName><ScreenShotRequested type="checkbox">0</ScreenShotRequested><DisplayTimeZone type="string"/></display>


Any idea?

after doing some research, I’ve found this problem caused by always_populate_raw_post_data on php.ini

After uncomment php.ini file, i will try. Hopefully this is the right things.

Wish me luck

Search on here for always_populate_raw_post_data. From memory it needs to be commented out, not uncommented

So this always_populate_raw_post_data = -1 need to be commented?
But after I tried to uncommented, the player options doesn’t show any warning or error. Is it right?

If setting it to -1 fixes it then great. It’s been discussed numerous times
here before. A simple search will turn up the answer. I can’t do it for you
right now

I did the search for you now I’m in front of a PC: