Xibo asking to log in infinitely

Since version 1.8, I have noticed strange behavior in the xibo.

  • When I leave the xibo standing on a screen for a long time, it logs out on its own.
  • I then loin again, I’m taken to the home screen [Dashboard].
  • When I try to access the same screen where the xibo was disconnected, the login screen is displayed again, as if I was not logged in.
  • I then log in, and I am taken back to the home screen, and when trying to access the area again, xibo asks for login again.
  • When this happens, the only way to be able to access the problem area is to clear the browser cache completely, there is no point in cleaning only the xibo page. Maybe that’s not it, but it’s the only relationship I’ve found.

There is no specific area for the error to occur, sometimes when I click [Layouts], sometimes [Playlists], sometimes [Players].

Right now, it’s happening when I try to open a specific layout for editing by clicking [Row Menu]> [Design].

It only occurs in one Layout, it does not occur in the others, which leads me to believe that it is something related to the screen that was being displayed at the time the xibo logged out.

I installed the latest version thinking that this error would have been solved, but apparently it persists.

There is a way to prevent the xibo from automatically disconnecting to try to resolve this.

Or, do you have a forecast to solve this?

CMS: 2.3.7
WEB / APACHE installation

Strange behaviour indeed.

Xibo uses the recommended/best practice way of handling sessions (a session is the thing that keeps you logged in), which includes various checks to ensure your session hasn’t been hijacked, etc.

Maybe you have a browser plugin or similar which prevents cookies from working, or alters your user agent? Some sort of “don’t track me” plugin or similar?

Is your Xibo user a super admin? Or a user with granted permissions?

Just some ideas :slight_smile:

Thanks,
Dan

Hi Dan.
Thanks for the suggestions.

Answering your questions, I do not believe it is the plugins, the error occurs in both chrome and firefox, both in standard tabs and in anonymous tabs.

  • I only use plugins in Chrome, in Firefox I don’t use plugins.
  • I only use the super admin user.

In my Chrome settings:
[Privacy and security] > [General settings] > The only option selected is [Block third-party coockes from anonymous browsing].

As I said at the beginning, I did an installation from scratch, using the latest version of cms, “before it was 1.8”. I also used a new subdomain,
I recently formatted my notebook and the error persists.

See that in March 2019 I had already informed this, and there was no return from anyone:

One of the ways I could try to solve this was to disable automatic logout and track behavior.

I know it is not a best practice, but it is necessary to carry out tests and find out if the problem is related to this.

I use a Manual installation, “no docker” I’m looking for a way to completely disable automatic logout only in xibo, without changing the php file to be able to find what causes this problem.

You may not have noticed this, as it is not something that always occurs, but it is something real and should have some attention.

I hope i can help solv this.

Right now, I went through the situation:

  • I left an anonymous tab open on the [PLAYERS]> [Players] screen.
  • I left, the xibo disconnected, and when I came back the other day, I could no longer access the Players page.
  • I had to clear the data from the cms in the browser Click> [Chrome SSL Chrome] > [Site settings] > [Clear data].
  • So I closed the anonymous window and opened another.
  • Only then I was able to access the players page.
    Note: In a NON ANONYMOUS window this procedure apparently does not work, it is necessary to clear the browser data completely.

Does anyone else have any idea how to resolve this issue?

Sorry you didn’t get an answer to your earlier message - we do try to answer as many as we can, but that is not always possible.

The problem must be something to do with the environment you have, because I don’t think its a general problem. Certainly we don’t have that issue with our development environments, Docker installs or Xibo Cloud.

Can you collect up the values of these settings in php.ini:

  • session.gc_maxlifetime
  • session.cookie_httponly
  • session.cookie_samesite
  • session.cookie_secure

Also follow the process in Report Fault when you have the login problem for your Incognito window.

It would also be interesting to see what you have in “Sessions” in the CMS user interface.

You can increase the timeout, but you can’t disable. Its just not possible. Web technologies are essentially “stateless” and sessions are needed to persist your state across browser navigation. What you’re seeing is that the “state” is being forgotten and we need to find out why.

Hello Dan.

Before answering your questions, I want to inform you that The same error occurred on my smartphone.

I will explain how to reproduce:

I’m using chrome mobile.

I access Xibo and went to the Players screen normally.

So I went to the chrome menu and clicked on the option: “Computer version”.

At this point Xibo has auto logged out.

I then logged in again, and from there, whenever I try to access the “Players” option from the menu again, I’m taken to the login screen.

I can only access the Players Screen if I uncheck the option “Computer version” of chrome.

It is a different way of getting to the same error.

Can you test?

“Remember, i use a manual non docker instalation”

Hi, It sounds like you MYSQL Database is running ove quota. Please clear log or reduce log and recude log to 10 days.
Try that and tell me .
Fred

1 Like

We use hundreds of different CMS installs for hours every day :slight_smile: and I can assure you that this definitely isn’t a general issue with Xibo, it is something specific to your installation.

I’ve asked you for some stuff which might indicate what is causing the issue in my prior comment, that is certainly the place to start.

The Xibo Community site uses cookies. What are cookies?