Xibo 1.8.5 - Login page does not log user in (IIS)

Hey guys,

Just installed a fresh Xibo 1.8.5 instance on Windows Server 2016 (IIS) and when I come to log in using my admin user that was created in the setup, the login page doesn’t actually log me in.

If I purposefully use an incorrect username/password, then it throws the regular red error message.

There’s nothing in the php log and nothing in the IIS log (Just 200s), and I’ve also tried resetting the password in MySQL. Could this be a session configuration issue? I can see the session files being created, but I’m a bit stumped.

Any ideas where I can start debugging?

Thanks for your help and kudos on the awesome software :+1:

What happens when you enter the correct credentials? Does that just reloads the page without any error? What if you’d open chrome (or other browser of your choice) dev console and see what’s displayed there when you try to log in?

Yeah, just a refresh back to the login screen. There are a couple of 302s and that’s about it (Nothing in the other tabs liek console).


Almost certainly.

We had to do some nasty tap dancing with PHP7 and sessions in order to make them work - the upshot of it all is that PHP5 didn’t call open/close when a session was regenerated, but PHP7 does.

Based on your symptoms I have a suspicion that on IIS PHP7 does not.

The below code comes from lib/Helper/Session.php on L#293

// PHP7 calls open/close on regenerate
// PHP5 does neither
if (version_compare(phpversion(), '7.0') === -1) {
    $this->insertSession($this->key, '', time(), time() + $this->maxLifetime);

Can you edit that and change it to comment out the IF statement completely - like:

//if (version_compare(phpversion(), '7.0') === -1) {
    $this->insertSession($this->key, '', time(), time() + $this->maxLifetime);


Based on your symptoms I have a suspicion that on IIS PHP7 does not.

I have assumed (perhaps incorrectly) that your running PHP7, which you might not be… it could just as easily be an issue with version compare on IIS.

Sorry, I didn’t specify that I’m on PHP 5.6.33. I’ve tried the alterations but I’m still hitting the samae issue.

Are there any specific PHP settings I could have missed? My session settings are almost stock, but they’re available here.

Thanks for your help.

I tweaked my config to the following:

session.save_path = "5;C:\Windows\temp"
session.auto_start = 0

And all seems to be working!