XIBO 1.8.5 in Debian 8.10


#1

Hello
I want to invade xibo on debian (8.10) and I followed the tutorial: https://community.xibo.org.uk/t/xibo-1-8-0-with-docker-on-ubuntu-16- 04/9392

only I encounter the following error message:

add-apt-repository "deb [arch = amd64] https://download.docker.com/linux/ubuntu $ (lsb_release -cs) stable"

E: The download of some index files failed, they were skipped, or the old ones were used instead.

14.0 KB received in 5s (2,365 o / s)
W: Can not Recover https://download.docker.com/linux/ubuntu/dists/jessie/stable/binary-amd64/Packages HttpError404

E: The download of some index files failed, they were skipped, or the old ones were used instead.
root @ Debian: / # apt-get install docker-this
Reading package lists ... Done
Building the dependency tree
Reading status information ... Done
E: Can not find the docker package-this

Do you have any idea about the origin of this problem?

thank you in advance


#2

The guide you followed is for Ubuntu 16.04, not Debian 8.10.

If you want to install Docker on Debian, you’ll need to follow the notes on the Docker website for that:

Once Docker is installed, the rest of that guide should apply equally well to Debian as to Ubuntu.


#3

when I run: apt-get update

W: Impossible de récupérer https://download.docker.com/linux/ubuntu/dists/jessie/stable/binary-amd64/Packages HttpError404

root@Debian:/# apt-get install docker-ce
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet docker-ce


#4

You would need to contact Docker in that case to find out why their
installation guide doesn’t work. It’s not something we can fix for you I’m
afraid


#5

Looking again I don’t think you’ve followed their guide properly. You have “ubuntu” in your repository URL, and their guide for Debian doesn’t use that at all.


#6

294/5000
Hello,
I have followed the steps indicated according to the following link : https://docs.docker.com/install/linux/docker-ce/debian/

my serveur is :
root@Debian:/var/lib# uname -r
3.16.0-4-amd64

I think that the problem is related to the list sources.list which does not contain the good urls of the mirroires considering the fact that I am in France.

Do you have an idea of what I can do to unlock this problem?

here is the contents of my /etc/apt/sources.list file

# Debian Jessie, dépôt principal
deb http://deb.debian.org/debian/ jessie main
# Debian Jessie, mises à jour de sécurité
deb http://security.debian.org/ jessie/updates main
# Debian Jessie, mises à jour "volatiles"
deb http://deb.debian.org/debian/ jessie-updates main

deb-src [arch=amd64] https://download.docker.com/linux/debian wheezy stable

deb http://ftp.debian.org/debian jessie-backports main


#7

Yes, however in your error message you have:

W: Impossible de récupérer https://download.docker.com/linux/ubuntu/dists/jessie/stable/binary-amd64/Packages1 HttpError404

So, I suspect you have an Ubuntu repository configured as well. Try looking in /etc/apt/sources.list.d and in that directory, see if any of the files there reference that URL.


#8

Hello,
the file /etc/apt/sources.list.d is empty

best regards


#9

when I run # apt-get update
I have the following message:

W: Unable to retrieve https://download.docker.com/linux/debian/dists/wheezy/InRelease Can not find “stable / source / Sources” entry expected in “Release” file: invalid line in sources.list or corro mpu file


#10

I’m afraid I can’t help with issues with Docker’s repositories. You would need to ask on their forums for help with that.


#11

I managed to put the right url sources in sources.list
when I go through the steps: https://docs.docker.com/install/linux/docker-ce/debian/#set-up-the-repository

I get the message:
root @ Debian: / opt / xibo # add-apt-repository \

“deb [arch = amd64] https://download.docker.com/linux/$ (. / etc / os-release; echo” $ ID ")
$ (lsb_release -cs) \ stable "
Traceback (most recent call last):
File “/ usr / bin / add-apt-repository”, line 95, in
sp = SoftwareProperties (options = options)
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 109, in init
self.reload_sourceslist ()
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 599, in reload_sourceslist
self.distro.get_sources (self.sourceslist)
File “/usr/lib/python3/dist-packages/aptsources/distro.py”, line 93, in get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: Could not find a distribution template for Debian / n / a


#12

I’m sorry I can’t help you. You need to ask on the Docker forums for help getting their software installed.