Xibo 1.8.2 no screenshots

I request screenshot, but got nothing back. Thumbnail field is empty. What is the problem?

If the ‘Screenshot?’ column has a checkmark, that means it wasn’t sent to the player yet.

What CMS/player version are you using please?
CMS seems to be 1.8 series, is it 1.8.2?

Is the player in 1.8 series as well?

1 Like

CMS is 1.8.2
Player is also 1.8.2… It was 1.7.9 but now its updated and same thing…

Is it docker or manual/custom installation on a webserver?

How is the XMR configured please?

Even if XMR is not correctly configured I believe in 1.8.2 it should send the screenshot over xmds as it did in 1.7 series (with that you’d need to wait for collection interval).

I assume this player is currently logged in to the CMS and up to date? (your screenshots do not show that)

Are there any log messages relevant to this action?

1 Like

I followed this tutorial…

Player is logged in to the CMS and is up to date.

Here are log messages:

It probably would be better to follow our guides or even better to install docker on ubuntu as that’s not too problematic and would save you some configurations later on.

In any case, what do you currently have in config.json regarding xmr public/private address and what do you have in CMS settings -> displays tab regarding the same?

1 Like

Here is what I have in CMS settings…

On server in config.json…

Right, so you don’t have public address at all in CMS settings and private address is on a different port between config.json and CMS.

That can’t possible work in the state it’s in at the moment.

Please see http://xibo.org.uk/manual/en/install_xmr.html

listenOn (private xmr address) is for CMS, so that can be on localhost - but the ports needs to be the same in config.json and CMS settings

pubOn (public xmr address) is for the player, so that’s most likely should not be localhost, but the CMS IP/domain it may very well run on 9505 port, but again the same information need to be in both config.json and CMS settings.