Xibo 1.8.1 Installation issues


Could somebody please help me because I am loosing my mind.
I installed Xibo 1.8.1, everything is ok exact the Media Gallery.
I don’t have such a good knowledge in htaccess. Could you please help me on this?

I installed it on a godaddy shared server plan, custom installation not docker.

I’ve moved your post to a new topic, as there is no reason to re-open months old topics, especially if your problem seem to be a bit different.

Could you please tell me what exactly is wrong? Do you have any logs / error screenshots that you could show us?

Side note: I’ll mention it again, shared server were never the suitable for Xibo, with 1.8 such solutions are even less suitable and definitely not recommended.

The error I am getting is DataTables warning: table id=libraryItems - Ajax error. For more information about this error, please see http://datatables.net/tn/7

I think it has to do with how I installed it and the structure of the folders…but can’t seem to solve for 2 days now :slight_smile:

Do you access you CMS with /web in the URL?

If you do then it’s configuration issue, you’d need to adjust the document root - http://xibo.org.uk/manual-tempel/en/install_environment.html

Then have a look at URL Rewriting section of the same manual page.

Yes I can access it via web but i tried all kind of modifications and setups but none worked.

I read the manual but seems like i don’t really know what to do.

If i give you my link user and pass, could you please have a look? :slight_smile:

It’s not something you can change in the CMS itself, normally you’d need to modify the settings on your webserver, I’m afraid I do not know if you can do that by yourself on shared hosting or not, if not you could try to contact whoever is running your web server and ask them to make this change.

Edit - Have a look here https://uk.godaddy.com/help/specifying-a-new-default-document-root-on-your-hosting-account-4175

I think that i should just rewrite htaccess, which I can, just don’t know the exact things to modify as my folders are

This is the actual error I am getting

http://www.mydomain.com/xibo/web/library [HTTP/1.1 301 Moved Permanently 128ms]
http://www.mydomain.com/xibo/web/library/ [HTTP/1.1 404 Not Found 257ms]

But on my server ZeroMQ is not working, can that be an issue? Is there a workaround not to use ZeroMQ when accesing the Media Library?