Xibo 1.8.0 - Infoscreen shows "files to download" for a long time

After adding an event to a screen (XMR running) the Infoscreen shows “files to download” for a long time even though the player already plays the media.

Collect interval: 1 hour

I can’t recreate this issue locally, I assume all files have (100%) and are in the player library and are also correctly displayed?

What’s the player status in CMS?

Info Screen: 7 files to download

Display -> Manage : The status for all media shows completely

Yes it is …

Now it’s gone.

It seems as if it went away after 1 hour.
Collect interval: is 1 hour

It’s rather strange, on player window it should be updated as it downloads new files, I’d be less surprised if in the CMS -> manage would show some files as not yet downloaded.

New trial

files to download : 6

Media in the Layout: Tide1, Tide2 … Tide5

You can check the CMS with the known data.

Problem seems solved. It only happens when client and CMS are on the same computer.

interesting, I actually did my test with that configuration, although in docker environment.

Both Client and CMS on Windows Server 2008. There also the screenshots do not work.

If request screenshot does not work, then that would imply problem with XMR configuration.

What do have set in public and private XMR addresses in CMS settings / display profile?

For external Clients:
Settings / Display:
XMR Private: tcp://localhost:51001
XMR Public: tcp://xxx.xxx.xx.242:9505
Firewall portwarding to:

Internal Client
is in its own display profile : tcp://
I think this will overwrite the global Settings / Display: tcp://xxx.xxx.xx.242:9505

“listenOn”: “tcp://”,
“pubOn”: [“tcp://”],
“debug”: true

I believe that private should be:

Could you try changing that?

and Public should be the DNS name or IP address that you access the CMS at (as the Player sees it)


so that’s probably correct.

Have now tried all possible variants. Screenshots do not work anyway. Is however no problem because the combination CMS and client on a computer only for test purposes.

Current configuration:

“listenOn”: “tcp://”,
“pubOn”: [“tcp://”],
“debug”: true

Settings Display
XMR Private : tcp://localhost:50001
XMR Public : tcp://xxxxxxx.com:9505

Displayprofil Internal Client
XMR Public Address : tcp://