Weather Module Size


#1

I’ve tried playing with CSS, changing Original Width/Height, setting display size, different templates, and I can’t get anything to change the size of the weather module to the correct dimensions. Currently I’m trying to get “Template 9 - Portrait, Current day, 4 day forecast” to work in a 320x580 region. In the preview it shows correctly, but on the player it’s always oversized. Am I doing something wrong? What do I need to do to customize it?

I’m using CMS 1.8.3 and Windows Client 1.8.3.


#2

i have same issue with cms 7.9 so i gave up


#3

If it looks correctly in the preview then could you please check two things:

  1. Right click on Windows desktop -> Display Settings -> Make sure that ‘Change the Size of text, apps and other items’ is set to 100%

  2. Double check browser emulation in Windows registry, that should be correctly added during installation though.


#4

Just checked and both computers have 100% selected. As for the registry entries they are in the WOW6432Node, but not in the other side. The computers are 64-bit, one is Windows 10 and the other is Windows 7.


#5

Thanks for your input. I’m assuming you meant 1.7.9, from my understanding they have reworked the Weather Modules for 1.8+. Maybe you should give them another shot, worse case scenario we can give the community input on what we’re seeing. Hopefully this would lead to a fix for this issue and will make this software better for everyone who needs it. This is an open source project and is therefore dependent on the community to some degree for input. Don’t just give up on it, try and work with the community and the developers!!!:wink:

Sorry, I’m just a huge advocate of open source and community driven software. I hope this didn’t come off as a rant.


#6

good recommendation. I will take a look at 1.8 series. I see a lot of complaints from users about docker. cms 1.7.9 has been good to me all of 2017. I just updated it to 1.7.10, later on I will install cms 1.8 to see. I bet transition effect now works in 1.8. a good weather module along with finance module could make xibo 1 in a million for life!

KWAME KINGSLEY


#7

Agreed, I definitely would love to see the weather working properly lol. I’m not really a huge fan of the docker containers either, I opted to install it on NGINX. It was fun getting it all setup, but everything works really well(with a few exceptions) and stable so far.


#8

@Fatboy125

Template 9, without overriding it (ie without making any changes to the CSS / original width/height), should look like this in CMS:


in player:

ie the same here and there.

Now, your screenshot looks to me like you’ve changed the original width/height to 320/580 which does not look great, although I’d expect it to look the same in CMS as well.

In short, could you please send my your layout via private message so I can take look at it?

That’s correct for 64bit OS (Xibo player is 32bit application)

@aponkye

All those modules are working correctly in the current release, docker is not required, although it is recommended by us, the reasons behind it are outlined here - https://blog.xibo.org.uk/why-do-we-recommend-docker/

Indeed there was a lot of changes between 1.7 series and 1.8 series, many components were pretty much re-written, there also are some features only available in 1.8 series.

Indeed, that’s one of the reasons why we have this community site and why we’re so active here, support is one thing but feature requests or bug reports that we got on this site are very much appreciated as well.


#9

I just checked the template to make sure I don’t have anything changed. The override the template checkbox is unchecked. Sent you a PM with the export of the layout.


#10

As a quick update, I have the CMS setup on one of my web servers running NGINX and it doesn’t seem to be working correctly. I just setup the docker version on my local machine(iMac) and it works correctly. Still working with @Peter to get this resolved via PM.


#11

For anyone that stumbles upon this in the future, I had an issue somewhere in my database. I dropped the database and ran through the install process again and it fixed my problems.


#12

@Peter took a look at my database and found there were some issues that could have been corrected by clicking the “Verify All” button on the modules page.