Weather Module not Syncing


I upgraded to 1.8.5 yesterday and noticed that the Weather module wasn’t displaying the current weather.

Logs show:
Unable to reach Forecast API: Client error: GET[API+LOCATION]?units=si&lang=de&exclude=minutely%2Chourly resulted in a 404 Not Found response: Cannot GET /forecast/player/[API+LOCATION]?units=si&lang=de&exclude=minute (truncated…)

I have since tried re-keying the API code, but I still get the errors and can not get a preview in the preview tab nor in the layout.

Has something changed, is it a bug? Or do I need to create a new darksky account?

We found this earlier today and issued a patch.

If you’re using Docker you can just pull and up the containers to resolve. If you’re on a custom install, you can apply the patch from here:

Great, that fixed it. Thank you!


I’m having the same issue. Unable to reach Forecast API: Client error: GET[APIKEY/LOCATION]?units=auto&lang=nl&exclude=minutely%2Chourly resulted in a 404 Not Found response: Cannot GET /forecast/[APIKEY/LOCATION]?units= (truncated…) .
I did the pull and up command for the docker container but no such luck. Is it possible that this is another bug as there are 2 in the GET request?

You’re sure you’ve not accidentally put the URL in to the API key field too in the Module configuration?

I’ve checked the API key field and you were right.
Now it works.
Thx for the help

1 Like

I wanted to try the weather app out.
I had upgraded to 1.8.5 the other day.
Saw there was a potential issue with the weather app so ensured that my forecastio.php was up to date
Registered on dark sky and received my api key
Added the ForecastIO module into my library and configured with api key.
Set up my long/lat (however unsure as whether I should be using + or - long lat values, but tried both anyway)
Added a page to my layout using the weather module.
All I get is a blank page - no error on display, no nothing, just blank.

Just inspected logs and can see this error;

Unable to reach Forecast API: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see

What am I doing wrong?