Video debian 20.04

Player Version 1.8-R5


I’m pretty new for xibo, but already managed CMS, install player on fresh ubuntu 20.04 machine and everything works beside videos. I tried tu put video as local file, from CMS (mp4) but its just dont work (files are downloaded to local library)
Files are played well by Firefox and VLC. The region that should play video is just empty…
Any idea where is the issue?

We’re having some issues with Video on some devices, related to GC drivers. See

We’re working on a fix, but its taking a while, sorry.

Can you please tell me how to revert back to a version of the xibo-player that has video working? Thanks

Unfortunately it isn’t an Xibo change which has caused this problem - it is a firmware/driver change.
We’re working hard to find a solution to it.

Ah yes I see that, things are working fine on my machines that I did not upgrade. You dont happen to know what I can revert on ubuntu to get this working again by any chance? Using synaptic I should be able to revert what ever package I need to what ever version I need.

So for me (yes its also broken on my own dev machine) it was the device manufacturers kernel update which broke it. If you’ve also got a new Kernel, you could try using the old one?

What is really odd about this, is that we’re pretty sure its only when gstreamer (what we use to play video) is inside snap.

Thanks, I’ll try booting with an older kernel and see if that fixes it.

So I reverted the kernel using grub-customizer back to 5.3.0-51 and its still not working, maybe I have to go back farther?

I really don’t know i’m afraid - I cannot get it working either.

The main contributor to the product is trying many things to solve it, but it is something outside of our control we think.

As soon as we have any options, we will come back to you.

Hi, is it worth trying ubuntu 20, or going back to 16 maybe? I just need a version of the OS that will play videos for one of my machines.

edit: well ubuntu 20 solves the problem, but the video is quite choppy now. At least its working.

We have narrowed down the issue to packaging - something in snap is causing the problem. We’re looking into alternative packaging to try and solve.

If you’re still available to assist, there is a release candidate to try: Xibo for Linux v1.8 R6 release candidate


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.