"User not found" when editing display

Hi, I have this issue where the error “User not found” appears and prevents me from editing my current displays.

I am running Xibo 2.2.0, but the error was also present in version 2.1.2. please see the screenshot.

This is getting more urgent every day, since I can no longer service any of my 70+ displays. Please advice.

edit: added debug info from log, and updated to 2.2.1

User not found#0 /var/www/cms/lib/Factory/BaseFactory.php(153): Xibo\Factory\UserFactory->getById(2) #1 /var/www/cms/lib/Factory/DisplayFactory.php(272): Xibo\Factory\BaseFactory->viewPermissionSql('Xibo\\Entity\\Dis...', '\n ...', Array, 'displaygroup.di...', NULL, Array) #2 /var/www/cms/lib/Entity/DisplayGroup.php(833): Xibo\Factory\DisplayFactory->query(Array, Array) #3 /var/www/cms/lib/Entity/DisplayGroup.php(700): Xibo\Entity\DisplayGroup->manageDisplayLinks(true) #4 /var/www/cms/lib/Entity/Display.php(670): Xibo\Entity\DisplayGroup->save(Array) #5 /var/www/cms/lib/Controller/Display.php(1153): Xibo\Entity\Display->save() #6 [internal function]: Xibo\Controller\Display->edit('35') #7 /var/www/cms/vendor/akrabat/rka-slim-controller/RKA/Slim.php(79): call_user_func_array(Array, Array) #8 [internal function]: RKA\Slim->RKA\{closure}('35') #9 /var/www/cms/vendor/slim/slim/Slim/Route.php(468): call_user_func_array(Object(Closure), Array) #10 /var/www/cms/vendor/slim/slim/Slim/Slim.php(1355): Slim\Route->dispatch() #11 /var/www/cms/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call() #12 /var/www/cms/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call() #13 /var/www/cms/lib/Middleware/Actions.php(150): Slim\Middleware\MethodOverride->call() #14 /var/www/cms/lib/Middleware/Theme.php(36): Xibo\Middleware\Actions->call() #15 /var/www/cms/lib/Middleware/WebAuthentication.php(131): Xibo\Middleware\Theme->call() #16 /var/www/cms/lib/Middleware/CsrfGuard.php(63): Xibo\Middleware\WebAuthentication->call() #17 /var/www/cms/lib/Middleware/State.php(121): Xibo\Middleware\CsrfGuard->call() #18 /var/www/cms/lib/Middleware/Storage.php(48): Xibo\Middleware\State->call() #19 /var/www/cms/lib/Middleware/Xmr.php(37): Xibo\Middleware\Storage->call() #20 /var/www/cms/custom/XiboForLinuxMiddleware.php(46): Xibo\Middleware\Xmr->call() #21 /var/www/cms/vendor/slim/slim/Slim/Slim.php(1300): Xibo\Custom\XiboForLinuxMiddleware->call() #22 /var/www/cms/web/index.php(127): Slim\Slim->run() #23 {main}

Could you provide further details as to the User Type, Page Security and Permissions against that particular Display? If you provide a report fault log whilst editing that Display, what does that show?

You mention that this issue occurred on 2.1.2, version did you upgrade from (when it worked for you)?

Hi Natasha!

I did not encounter this issue before 2.1.2.
I have a super administrator role, and it happens with all our Super admin users, even the built-in admin thats default with the Xibo install.

At some point a user was deleted instead of just retired (by accident), it was on 2.1.2. I don’t know if the error was introduced then. It was back in September, and I havent been editing the displays since then.

I upgraded from 1.8 - but I am confident it worked during 2.1.2, possibly before the user deletion.

I exported the full debug log here:

It appears you have a dynamic display group which has an owner that does not exist anymore which is throwing the error on Display>Edit, because that particular display (id 35) is a member of that dynamic display group as it matches the criteria.

Could you try changing the Owner of that display group from the Displays Group page>Permissions.

Hi Natasha!

Thank you, that worked!