URL rewriting IIS not working


System :
-Windows Server 2012 R2
-Xibo CMS : 2.0.1

I followed this instruction page for IIS URL rewriting : https://xibo.org.uk/docs/setup/prepare-your-environment

But when I try to go to the login page “localhost/login”, I got an http 404 error. I need to put “localhost/index.php/login” to get the login page.
My website point to the “web” folder like it is recomended.

What I need to do for resolve my problem ?

Thanks in advance,

IIS does support URL rewriting so you shouldn’t have to put index.php indeed but it might be that IIS does not enable URL rewriting by default.

As this is not specific to Xibo and we don’t have expertise with IIS please check with IIS Microsoft help and support forums.