Unable to delete regions Xibo 1.8.3

Hi there,

I recently installed Xibo 1.8.3 on my webserver,

The server meets all of the requirements except for the filesize upload but I can easily fix that.

When I try to delete a region or image I just get a spinning cog that doesnt stop.

I made sure that the DocumentRoot is pointing to the right place. (it doesnt show “web” in the domain name")

Does anyone know what could be causing this?

Please run through the Report Fault process within the CMS and see what is logged. It’s also well worth clearing your browser cache too.

Hi there,

I ran it and I get the following in the log:

9,d3ec703,“2017-12-29 10:33:03”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
10,b6c3151,“2017-12-29 10:33:41”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
11,d12db98,“2017-12-29 10:34:41”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
12,e5b4ab5,“2017-12-29 10:35:41”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
13,ba5c4e7,“2017-12-29 10:36:31”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
14,d92c315,“2017-12-29 10:37:32”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
15,0c3076d,“2017-12-29 10:37:59”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
16,7bb0b05,“2017-12-29 10:38:19”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT
17,b38c74c,“2017-12-29 10:38:32”,WEB,/layout/status/2,GET,“Layout has empty region”,ALERT

The above is the process I go through whn trying to delete an image from a layout. I can add but not delete.

Is there any update as too how to resolve this?

Can it have anything to do with folder rights?

Or is it a php problem?

Any help on this is much appreciated.

Your log doesn’t show anything useful. Infact it doesn’t show you accessing the layout designer, loading the layout etc, so I don’t think you managed to run the wizard correctly.

You need to start it running, and then step through to the point where it tells you to recreate the issue. At that point, you need to load the layout, and then try and delete your region. Then return and collect results.

I presume your environment meets all the requirements? PHP 5.6, MySQL 5.6 etc

Hi, thanks for the response.

Apparently when I try to delete an element of a layout it doesnt bring anything up on the log.

But I realized that the problem is not limited to just layouts. I cant delete anything including images from the library.

So I rerun the test and I tried deleting the layout elements which wont show anything and deleting an image from the media library which produces this message: Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR

The cog on the Delete button just keeps spinning.

Please see the full log here:

81,71264b2,1/3/2018 15:30,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
82,87f4d7c,1/3/2018 15:30,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
83,0fcb23f,1/3/2018 15:30,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
84,32f7610,1/3/2018 15:31,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
85,a791d32,1/3/2018 15:31,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
86,02dda19,1/3/2018 15:31,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
87,0c2c134,1/3/2018 15:32,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
88,bfc92df,1/3/2018 15:32,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
89,6f13341,1/3/2018 15:32,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
90,7c6db4c,1/3/2018 15:33,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
91,077c2bb,1/3/2018 15:33,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
92,6dbfa61,1/3/2018 15:33,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
93,cf5e7ff,1/3/2018 15:34,WEB,/clock,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
94,34fb5f5,1/3/2018 15:34,WEB,/login/ping,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
95,d9f2a6b,1/3/2018 15:34,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
96,d9f2a6b,1/3/2018 15:34,WEB,/layout/status/2,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
97,15eb0e9,1/3/2018 15:34,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
98,21cc524,1/3/2018 15:34,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
99,06326ce,1/3/2018 15:34,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
100,00557c6,1/3/2018 15:35,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
101,b9f03e6,1/3/2018 15:35,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
102,ac01e37,1/3/2018 15:35,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
103,84cb438,1/3/2018 15:36,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
104,fa7d139,1/3/2018 15:36,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
105,38a2158,1/3/2018 15:36,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
106,32a0422,1/3/2018 15:37,WEB,/clock,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
107,ea6d924,1/3/2018 15:37,WEB,/login/ping,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
108,88f66e7,1/3/2018 15:37,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
109,88f66e7,1/3/2018 15:37,WEB,/layout/status/2,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
110,c7ffd82,1/3/2018 15:37,WEB,/clock,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
111,62b63ec,1/3/2018 15:37,WEB,/login/ping,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
112,c56e83d,1/3/2018 15:37,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
113,c56e83d,1/3/2018 15:37,WEB,/layout/status/2,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
114,4d90422,1/3/2018 15:37,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
115,be3b403,1/3/2018 15:37,WEB,/clock,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
116,e944649,1/3/2018 15:37,WEB,/clock,GET,Template Missing Exception Type: Xibo\Exception\ControllerNotImplemented,,ERROR
117,4960d21,1/3/2018 15:37,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
118,775e0ea,1/3/2018 15:37,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
119,30faf50,1/3/2018 15:38,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
120,4aab81c,1/3/2018 15:38,WEB,/layout/status/2,GET,Layout has empty region,,ALERT
121,4f7337a,1/3/2018 15:38,WEB,/layout/status/2,GET,Layout has empty region,,ALERT

Thank you again for the help.

Also, yes my enviroment meets all the requirements except for the ZeroMQ which I dont plan to use.

Unfortunately this doesn’t really give us anything - apart from being entirely unexpected as it implies an issue with the code rather than configuration.

Please can you update the server mode to “Test” in the CMS settings (or SERVER_MODE in the settings table) to see if we can get more logging. The extra debugging we would expect doesn’t appear to have been enabled in your previous attempts.

Do you have your own theme or code running on this installation?

After a PM discussion it turns out the webserver in question is running DirectAdmin which disables PUT/DELETE requests. See http://forum.directadmin.com/showthread.php?t=55465 for more information.

Thanks Dan for helping me narrow down the problem.

Will take it from here.

Best Regards,