UHD-Support in Portrait-Mode


We currently have the following configuration in our company:

  • Xibo Server Version 1.8.1
  • 12 x DSDevices DSCS9, Android 6.0.1, Xibo Client 1.8 R102
  • 12 x UHD displays 43 inches, portrait

Currently, even after the most intense tests, it is not possible to display pictures (png) or videos (h264) in a UHD portrait (2160x3840) reasonably. Images and videos are always displayed with half the resolution - so with 1080x1920 and also very badly down-billed. All HDMI cables used support UHD. The display of pictures and videos in FullHD mode works smoothly.

The following settings have been changed:

  • Display Settings on Portrait UHD (2160x3840)
    O New configuration »Display UHD portrait«
     Orientation: Portrait
     Screen Dimensions:0,0,2160,3840
  • display
    O Edit> Advanced> Settings Profile? > »Display UHD Portrait«
  • Resolutions
    O New Configuration »UHD Portrait«
    O With: 2160
    O Height: 3840
  • layout
    O Edit> Background> Resolution> “UHD Portrait”

It appears that the Xibo server does not deliver the data to the clients in full UHD resolution. We have invested a lot of money in the system and would really like to solve this problem - is this the best way to proceed?

I would be grateful for a feedback!

Best regards,
Stefan Mittelstädt

Are the images / videos in this resolution as well? Or at least in the same aspect ratio?

Xibo certainly should not change file resolution on upload, it should be the very same in CMS library as it was before you’ve uploaded it there.

If you download it from the CMS library is it in the same resolution/ratio as it was before you uploaded it to the CMS?

If the screen is in portrait orientation as well as layout resolution, display profile (which seems to be true) assigned to the the device and the files are also in the same aspect ration then I don’t see why wouldn’t be displayed correctly.

There was a long list of fixes between 1.8.1 and 1.8.2, if possible I’d highly recommend upgrade to it as well - although in 1.8.1 want you want should work fine.


I have updated to version 1.8.2.
Unfortunately the situation has not improved. Below you will find the link to the original mp4 file (Xibo file name 129.mp4):

The file is the downloaded original from the Xibo library.

I have also included a screenshot of the Xibo client’s status:

I hope that the error can be somewhat limited.

I am grateful for any solutions!

In this case it would seem it can’t display it at all?

Is it H264 encoded .mp4 file?

Does this display has any problems displaying videos in landscape mode or does it happen only in portrait mode?

You could try switching to External storage (in Xibo for Android settings)

failing that, you could try switching to textureView rendering, Display settings page -> Edit display profile assigned to your device -> Troubleshooting tab -> ‘Use Surface view…’ (disable that)
restart Xibo for android so the device picks up the change - it’s also visible on the status screen, what rendering is in use as there is a line about it there.


H264: yes

Video-Problems: yes

I have now tested our system with the following configurations and visualized the results here:

I hope the error can be somewhat limited.

With regards Stefan Mittelstädt

Thank you for your detailed report.

I don’t have a sane way to test it against 4k monitor here, but at least from the DSCS9 specification it should be able to output this resolution if needed - HDMI: HDMI 2.0a up to 4K @ 60Hz and your device setting screenshot seems to confirm that.

1080p content landscape and portrait is displayed fine, but 4k isn’t.

Could you try what I’ve suggested about changing the rendering method to TextureView instead of SurfaceView to see if that will make any difference please?

Are all those tests done with 1080p/4k landscape/portrait videos only or did you try some 4k images for example as well?

Hello, changing the rendering method make no difference.
Also in UHD-Portrait modus pictures will be displayed wrong.

In my opinion, there is a server-bug…

That only happens when everything (layout, image, display profile, TV) are all set to 4k resolution?
and when everything is set to 1080p then it fits as expected?

Regarding video, I believe the video you’ve posted is in 60fps, it would be highly recommended to keep videos at or below 30 fps for any android device.

Unfortunately I don’t think we’ve tested the 4k content on 4k TVs as of yet (we don’t have a reliable way of doing that at the moment), although I believe DSDevices did test that in house.

Could you try contacting them directly via their website, perhaps send them an example video / image that you use (in 4k) and ask them to test it locally please (also on 4k TVs in 4k resolution of course)?

I’m having the same problem: 4K 75" screen and android player running on beelink GT1 Ultimate.
I’m running it on portrait mode and with 1080 layouts, it runs ok. With 4k layout runs ok too but only if the contents inside are 1080. If i put a 4k content it won’t play.
After reading this, i’ve forced the screen dimensions to be 2160x3840 as it appeared 1080x1920 before doing so. I’ve changed the layout to 4k, i also created my own 4K resolution as the original wasn’t working but i end up with this same result: only 1/4 of the layout appears… It looks like it is set for 2x2videowall and it’s only showing monitor 1.
Any ideas on this?
Thanks a lot!

If you’ve forced the screen size, then that’s the issue right there.

Alot of the 4K devices on the market will output a 4K signal, but internally they run at 1080p and upscale the output.

If you force the device to run Xibo in a window larger than the screen buffer, then you’ll only see the top left of the output.

You should set the device to output 4K, and then set Xibo to detect screen size automatically. If Xibo still shows 1080p on the status screen, then the device is upscaling the output from 1080p to 4K. In that case, there’s nothing Xibo can do there. The device is limiting the resolution.

1 Like

Hi Alex
Thanks a lot for your feedback.
It looks like so. I got to that conclusion in fact: it runs at 1080p. Nevertheless, I’ve tried also with windows, everything is in 4K, as windows detects it, but when xibo runs, the same thing happens: only a fourth of the layout appears. I end up with the same result as running on android.

Check the Windows Display Scaling settings. By default, on UHD screens, Windows scales all applications up to 150% their size to that fonts etc aren’t so tiny. If you set that back to 100% it may solve it for you.

Thats bad, we need to display 4k Layouts to a 4k display, and I have the same problem with the reccomended DSCS9. Please, could you from Xibo please talk to DSDevices to find a solution?

Thanks @ChrstianM82. I’m speaking with DSDevices about this currently.

Hi, same problem here – any kind of solution coming up?

There’s discussion going on between DSDevices, Amlogic and ourselves. We’ve added a note to the Recommended Hardware List to explain that the device is capable of outputting 4K video with Amlogic’s own video player app, but that normal apps (including Xibo) aren’t able to do that at the moment.

Hi, any updates on this Alex? Unfortunately I bought seven DSCS9’s before you added that note. :frowning:
They are great little devices otherwise.

When we have anything further to share there will be an announcement. If you’re not happy with the DSCS9 then I would be in contact with DSDevices and I would expect them to be able to resolve this for you.

DSDevices told me that the DSCS9 will never be able to run the Xibo App in 4k because Amlogic won’t change the firmware.

So, is there any Android Device capable of running Xibo App in 4k?

Amanda has just given me the same information, and I have updated the list accordingly.

I know I’ve seen screen captures from Customers showing 4K resolution on the status screen, but I don’t have details of what they’re using I’m afraid.