Ubuntu 14 install not woking

I have tried to get xibo up and running for the last week now, on a bare bones ubuntu 14.04. I have followed so many install guides with no luck at all (installed ubuntu on my laptop now 5 times). I have even installed Ubuntu desktop (twice) and tried that as well - no luck.
As I am new to servers and xibo am I doing something wrong?
I have ubuntu server on my laptop connected to a netgear N600 router (do I need to do anything with the router or setup a static ip -if so how).
I try and access xibo from my main pc - which is running Ubuntu 15, using the firefox web browser by entering ;
https://TAAVNDS/Xibo or http://etc
Nothing happens and then I get file not found.
Do I need to setup acess for users and groups other than www-data? is this correct anyway?
my aim is to have our school runing xibo for introduction data, wh&s, security and First Aid information through various PC/TV screens. I would like to have a ubuntu 14 or 15 barebones server with one login only (the one you create when installing ubunut), and then remotley login via firefox web browser to manage all of the clients etc…
Should I change www-data to my username? Should I create a new group and change the attriibutes to that as well? or is www-data a specific group I need.
PS I can get the apache2 main webpage up, does this help?
As I am new to this is there a really simple step by step guide for the lowest common denominator here (me).
Or could this be an issue with router/firewall stuff?
In saying that the laptop has ubuntu standard on it and I still could not get the xibo startup webpage running…
I am not going to let this beat me, just need help.
Also are there any other configuration details I need to change? Some xibo examples change heaps of data…
Sorry for long thread

Hi Mick,

Could you please have a look at this guide (yeah I know another guide, but perhaps you didn’t read it yet)

Then carefully follow his instructions on a fresh installation and see if perhaps you missed something before or is problem somewhere else.

Thank you so much, I have reloaded ubunter server (bare bones) and have xibo up and running although with some minor issues regrading getting mcrypt to work (just googled that) but have some minor issues still regarding max_file_upload:
You probably want to allow larger files to be uploaded than is currently available with your PHP configuration.
We suggest setting your PHP post_max_size and upload_max_size to at least
128M, and also increasing your max_execution_time to at least 120
Done that and restarted apache2 server

Internationalization International
Support for formatting Dates, Numbers, etc.Translations will still
function without this PHP module, however dates, times and numbers will
not be shown in your locale.
Not sure how to fix that one.

Apart from that I am in and looking around.

Much appreciated for all of your help. I love the support here.



Hi Mick,

Great, I am glad that it is working for you now! :smiley:

Are the upload_max_filesize etc settings fine after you made those changes?
For more documentation regarding php.ini settings for max upload file size etc, see this topic:

For your minor problem with Internationalization, it should be easy to fix that too, please see this post: