Twitter Module Issues

Hi,
I’m having issues with the Twitter module and have posted for help previously on GitHub. Dan and another ramdomer were discussing the problem and Dan managed to fix the issue for the other person but that resolution didn’t work for me.

I have since upgraded to 1.7.4 and this issue is still present.
The error im having from the log is:9204 15-10-21 03:12:33 CMS Twitter getToken Error contacting Twitter API: SSL certificate problem: unable to get local issuer certificate

I have done the process of adding curl.cainfo=c:\php\cacert.pem and download the .pem file.

I am behind a HTTPS proxy (Smoothwall) which is all entered correctly in the Network settings of Xibo.

Any help on this would be great! :slight_smile:

Thanks
Arran

You need to add your Smoothwall HTTPS CA certificates to the end of the cacert.pem file.

Smoothwall basically does a man in the middle attack on the HTTPS connection and pretends to be Twitter. Curl needs to trust Smoothwall for it to work.

Alex, Thank you soo much! It worked!
Great support for a great product! :slight_smile:

Regards,
Arran