Twitter module: feed not updating -> CMS connection dropping?

Hi, I’m setting up my first Xibo system on a DSCS9 device.

Adding a twitter feed to my layout, is working fine when initially, but it isn’t receiving any updates.

Am I misunderstading the timing confiugration?

  • I’ve tried a twitter feed both my regular layout combined with other content, and on a seperate layout.
  • CMS settings are set to the correct timezone

update interval under advanced is set to 5 min
Even if I set the duration to 120s and the update interval to 1 min I’m experiencing the same issue.

Update:
Caching is disabled on the display, running xibo from the cloud.
Enable caching of Web Resources? 0

Update2
Also: sometimes my layouts stop looping, and the screen remains stuck on 1 layout. I’ve enabled logging & audit trail

Update3
My connection to the CMS seems to be dropping, leading to a stop in looping (and updating) of layouts.
Currently the display status is signaled as “cloud” in the CMS, they android display is reachable via teamviewer.
Any idea on how to troubleshoot this? My DSCS9 has a wired internet connection
System was delivered runnig 1.8 v104. I’ve just pushed R108 to the CMS, hoping for an improvement :slight_smile:

So R108 will definitely help

Is it a Cloud CMS or one you’re hosting yourself?

The system connects to the Twitter Search API, which provides “selected” tweets (not all) and there are limits set as to how often you can query it without being blocked.

On Cloud we prevent a search for a specific term happening more than once every 1 hour (see Xibo Cloud CMS Defaults and Restrictions)

If you’re running a local CMS with your own API key, you can lower that setting in the Module configuration for Twitter - but Twitter may limit you if they think you are making excessive requests.

I’m using the Cloud CMS.

We cache requests to the Twitter search API for 1 hour.
is a piece of info I missed, Are there any alternate solutions? I’m displaying a combination of 2 public accounts tweeting traffic info.
A 5min delay is OK, but 1h defeats the purpose :wink:

If you have your own Twitter API keys then we may be able to apply those to your CMS for you - in which case if Twitter block your keys for excessive searches then it won’t impact everyone else. You’d need to open a ticket with our support desk with the keys you want to use.

Thanks for the quick and quality information!
I’ll open a ticket

Update: Xibo keeps on running after updating to v108 as well

1 Like
The Xibo Community site uses cookies. What are cookies?