Trouble with Weather Icons

Hi there,

i used a Xibo-Client 1.7.9 on Windows 10 Stick-PC in our entrance hall. Since 2 weeks or so the client show no more of the Weather-icons.
I clear the Xibo-Library, No improvment
I checked if the Weather-Icon-Files are copy to the client. It is. (i dont know exactly is it the right icon set?)
I go in CMS to “Modules” an do a “Verify all”, No improvment
I cleared the cache of the Browser of the client, No improvment
I reinstall the Xibo-client-software, No Improvment

In the preview in the CMS everthing works fine but not on the Display.

Have anyone a idea, whats wrong with my Client.

Thank you all Guys for your Support

Could you show us a screenshot of status window on your player?

and see if those weathericons files are included in the required files list there?

I believe there was an issue with those, but that was in 1.7.4 or 1.7.5, and you’re using 1.7.9 CMS? (you mentioned only player version, so I’m assuming CMS is in the same version).

Hi Peter,
you are right. Cms and Client are on Version 1.7.9.

I read about an issue in 1.7.4, but not on 1.7.9, because it is fixed in 1.7.5.

The files are inculded in the list, i make 2 Screenshots so you can see.

i hope it helps you, to figure out what’ss the problem.

Greetings from Germany

Today i set up an new Pc to test my configuration.

So i install the Xibo-Client, configure it right, and it works out of the Box with the Icons.

My test’s go’s on, i hope i can fix my problems.

I’m glad it works on new PC, although I’m also still confused why there were issues on your earlier test device.

I can think of only one item that you didn’t mention and that can have an impact on it, the browser emulation settings (and IE11 installed) - although that should be correctly set during installation of the player.

If you want to try and debug this further, then you could look for errors in .htm file from player local library when they are open in the player local webserver.

ie Load correct .htm file from player library in the local webserver (in IE)

I believe it should be http://localhost:{PORTNUMBER}/{FILENAME}.htm

port number by default is 9696
You can double check that in Display settings page -> Edit display profile assigned to this display -> Advanced tab -> Embedded Web Server Port

file name - is the .htm file name that corresponds with this weather layout in the player library it will be for example something like 854.htm
so then you’d navigate to localhost:9696/854.htm

Xibo client must be running for the local webserver to work and obviously you’d need to check it on the PC that runs the client.

Once that’s loaded, presumably also without icons, you can open the console and see if there are any errors there.

Hi Peter,

i have opend the html files from the client xibo library and i can see the areas with the Information in it. The icons are still there in this html files.

But in the Player the Icons are not shown.

I check the browser emulation and it set right. Also i set the IE back to Factory defaults, without a positive result.

im a little bit helpless about that…

is it possible that a IE update make this trouble ?

Today i set up a new client again with Windows 10. Works out of the Box!

I have the following Problem: The Stick-PC in our Entrance-Hall is very special and it cost me more than one day to set it up with a new Windows-installation. In this time our customers have no information where the next meeting/training uso. is.
So it’s the last way if nothing works and we can not fix the problem.

Any Ideas a very appriciated.

If it’s not browser emulation, overlapping regions and since the same layout works on other players, then probably that’s not it, I’m slightly out of ideas.

Did you just open the .htm files in browser or did you also try to open them in the player local webserver as I suggested?
I’d assume the icons will be missing there too and perhaps IE dev console will tell us why that’s the case.

Hi Peter,

Yes i open the .htm files in the Browser not over the player local webserver. If i have litte bit more time i try it with the local webserver.

Thank you for your support

HI Peter, now i know what you want…

but: i can’t find where there the empedded webserver port is configured, and so i can not call the “website” and can not use the IE11 dev console to debug.

I try your example, without a result.

Can you give me more or better information, how to check if the webserver running, and on which port.

Thank you

9696 is the default Port.

Xibo player must be running on the machine in order for you to access it.

Sorry Peter;

but der is no “Embedded Web Server Port” in the “Advanced Settings” when ich chose “Edit” unter the “Display Settings”.

and i call over the Network: http://IP_of_Display-PC:9696/91ff77959ffe26099f5d7e9093157cda.htm or must i do the call on the Display-PC itself?

Is it possible that we do a chat (i can not call) over skype or do a teamviewer session ?

I didn’t mean you to edit Display, but to edit display profile, perhaps it will be clearer on screenshots:

It will need to be on localhost on the PC running the player.

Hi Peter, yes i know, but on my Xibo 1.7.9 there is no embeddet Webserver Port… I think we use diffrent versions of Xibo.

OK i go an check it on localhost…

i try: http://localhost:9696/91ff77959ffe26099f5d7e9093157cda.htm an without a result: Allways Access denied.

ah right, apologies I forgot that you’re on 1.7 series.

I think it should still run on the same port though, it’s just not exposed in web ui.

Ok you are very welcome! i test it: (see my post above) without an result.

Sorry for my bad english i’m from germany…

Today i have a little bit of time an make the User-Profile on the Display-Pc new.

I change the User to Admin, delete the User-Profile-Folder of the Xibo-User, reenter the Xibo-User (its a Domainuser) so a new Userprofile was created.

But the result ist the same: Always no Wether Icons on that Display-PC…

It works fine with my laptop, so im still frustrated !

Greetings from Germany

Guy’s i don’t know what’s happend…

Today, update for Windows 10 on the Display-PC installed and after a reboot:

Bäämmm -> All Icons are back…!?

I dont understand whats going on, but im happy with that.

Hmmm… ok this week i updatet the Xibo-Cms from 1.7.9 to 1.7.10. Would that fix the problem ?

Thanx for your Support


It is possible, although I would really expect verify all on modules page to fix that in the first place, in any case, I’m glad to hear that in 1.7.10 it does work correctly for you!