1.8-rc1 install media problems

Fresh install, all requirements are proper, library has full permissions.

Getting DataTables warning: table id=libraryItems - Ajax error. For more information about this error, please see http://datatables.net/tn/7

Have re-installed twice, new db and still getting this error. Haven’t done anything else, no uploads, no layouts, no displays, nothing.
Been running 1.7 for a month on this server and all requirements look correct.

This is almost certainly a mod-rewrite issue - i.e. mod-rewrite isn’t correct. Can you follow the diagnosis section of the link you provided so we can see what you’re getting?

Hi all.

We encountered the same error after upgrading to 1.8-rc1 on IIS. (We had experienced no problems with 1.7.x)

After digging through the failed response using Firefox developer tools, the cause of the error was a 404.15. This is an error that is thrown by IIS upon rejecting a query string that is too long.

The query string on in the affected request was about 2400 bytes; IIS has a default limit of 2048 Bytes (2KB). It seems that Tempel frequently uses query strings that are larger than 2 KB.

After modifying in IIS: Request Filtering -> Maximum Query String (Bytes) to 4096, Xibo worked as expected.

Dan, it may be a good idea to put in the documentation for those using IIS that they will probably have to modify this setting for their installation to work.

1 Like

Fantastic, thanks for the heads up.

As a matter of interest this is the “datatables” plugin which sends a whole load of data down in the GET request. It can be switched over to use POST, but that kind of breaks the “REST” model we have going. I’ll monitor it.

Thank you for this. I was smashing my head on my desk trying to figure this one out.

That solved my problem, thanks…
Michael

I know this is an old topic, but I’m having the same issue except mine is throwing a 400 error. Can’t figure this one out. I’m running a fresh install of 2.3.10 on a Windows Server 2019 with IIS. I have a failed request log file, but I can’t upload it here. I’ve attached the very top of the log in an image.

Same! same issue in this version… 2.3.7

Fixed!!

Must change in IIS: Request Filtering → Maximum Query String (Bytes) para 8192

and Done :smiley:

The Xibo Community site uses cookies. What are cookies?