Trouble finding xibo homepage after installing on Docker


I’m new using Xibo and I’m trying to setup installation on Docker Linux.

After running docker-compose -f cms_remote-mysql.yml up -d, docker-compose ps shows me both services are running and when I hit localhost:80 , “it works!” message is displayed.

But I can’t find where is xibo homepage. I tried localhost:80/web, localhost:80/index, localhost:80/home, but no luck so far.

Any tips?

Thank you for your message. There were a couple of things about your post that sound like issues.

You first mentioned that: docker-compose ps shows me both services are running. When you up your Docker CMS, you should see 3 containers: one for your CMS, another for XMR and the third for your database (mySQL). Can you confirm what version of CMS you have installed and what the 2 containers are that you are seeing?

The second issue is that you mentioned when I hit localhost:80 , “it works!” message is displayed. The It Works message is associated with web servers such as Apache, you should not be seeing this when you try to access your CMS. When you type in the IP or URL for your CMS , you should see the Login page. It sounds like you have a web server installed and running on Port 80, you will need to either stop that service or configure alternative ports for your CMS so that the 2 services do not conflict.

Many Thanks.

Hi @DanBW

Since I use cms_remote-mysql.yml there are only two containers available, one for xmr and another for cms-web. I’m using latest Xibo Docker installation ( 2.0.3 version.

And about the second issue when I ran systemctl status httpd, it shows:

Unit httpd.service could not be found.

So I guess there isn’t any apache web server running, right?

I forgot to mention before but I’m using Red Hat 7.5 and my docker version is 18.09.06.

And btw thanks for your time for trying to help me.

You are correct about the remote mysql database, my bad.

Regarding the search for an Apache server, it may not be Apache specifically, that was an example of a server that displays the it works message once you set it up and you navigate to the IP and Port it is running on in a browser.

Whatever service is causing that message to show I cannot say for certain but CMS does not display that message when it is set up, it simply takes you to the Login page when you enter the appropriate IP/URL and Port into a web browser.

Can you run the docker ps command, not docker-compose ps and include the results in your reply please?

Many Thanks.

That’s my result after running docker ps command:

b5b6c83c8902 xibosignage/xibo-cms:release-2.0.3 “/” 7 minutes ago Up 7 minutes>80/tcp xibo-docker-203_cms-web_1
104740e00696 xibosignage/xibo-xmr:release-0.7 “/” 7 minutes ago Up 7 minutes>9505/tcp, 50001/tcp xibo-docker-203_cms-xmr_1
038466183c3d portainer/portainer:latest “/portainer -H tcp:/…” 27 hours ago Up 27 hours 9000/tcp portainer_portainer.1.u2ssiuoci8htw801sxeen3mmh
f10b6244f52d portainer/agent:latest “./agent” 27 hours ago Up 27 hours portainer_agent.netdb1po43aal4zvq7rmxqob3.xzjnbhbj0kiaxote4pjqig7a1


Do you have any clues to me in order to solve this problem?

Thank you for your message. I do not have another suggestion on how to resolve this issue, as I cannot explain why you are seeing the “It Works!” message. The Xibo CMS does not display that message when you are setting it up, you should only see the login page.

I’d be interested to know what happens if you docker-compose down your containers and try going to localhost:80. The containers will not be running so in theory you should not see anything, only a site cannot be reached message. is that the case with your setup? otherwise I would recommend removing your installation and starting again to see if you encounter the same issue.

Many Thanks.