Text on layout not visible on Android clients (licensed)

I forgot to tell I’m on a Linux based machine, and now you mention it. I have to review all folder rights, i will get back :slight_smile:

I am on CMS 1.7.4.and updated all 5 MINIX NEOX5 Android clients to the latest firmware!

I noticed that in the new client firmware you cannot get into setup anymore, the upperbar is hidden right away and cannot be opened by mouse or keyboard, at least I did not find a way (i tried it all) very cumbersome :frowning:

Real critical issue with latest client firmware
In designer layout text-region is visible and editable, however it does not show on our Android clients… I’m also struggling with fonts (I have uploaded them to media library and in designer I can choose the font but there is no visibility of the font on the client output screen…

It looks like text is not showing up at all…I have a screen in designer full textregion, but on client only the backgroud is presented and no text… very disturbing issue!!!

It worked fine in older Android client at development premises. When I took the setup to the customer premises and started with the implementation I struggled with the layouts and font size from day one :frowning: I checked IP-adress and noticed the library did not update to the new one. When correcting it in the 1.7.4. CMS you have to redesign your background etc…etc… Fonts are also lost! and have to be deleted and newly uploaded (check naming!!!)
(I now have html which somewhat suffice a bit, but customer still is not very amused :frowning: )

This certainly is not a wysiwyg experience in the 1.7.4. designer software (unfortunately)

What can I do to resolve text not showing up on the clients?
Should I reinstall older client software?
regards Ron

I have also ran into a very simular problem with the fonts not working correctly and Android clients. I would suggest checking folder permissions to make sure everything has the correct permissions. If you are running the CMS on Windows you will need to set some very specific permissions for the IIS to get the correct access to the folder where the module files are stored. You will also then need to run the “Verify All” process under the modules section of the CMS. (Note that our test system is using WAMP on Windows and we have far less issues with permissions.) I would suggest turning on logging in the CMS first, so that you can see what might be happening if you still have a problem.

I am assuming here that when you upgraded the permissions have not been reset for the new folders that were created.

Please don’t edit responses like that. It makes it very hard to track the flow of suggestion and trouble shooting. Please use the reply option so that we, the community, can help you better. :grinning:

Yes please check the folder permissions and run the verify all option.

For the strange behavior on the ability to get to status and what not, you might try clearing the cache and setting in the Android setting. You will need to redo the authenticate with the CMS server afterwards.

I’m sorry the reply did not give me an new post editor in Google so I tried my best to reply in a way it would work…
thnx for the quick reply and answer… :relaxed:

I have checked folder permission and I can browse it… However all 5 Minix Clients are still not showing text regions, were as the datasets are normally shown! bee it with cumbersome html markup (wysiwyg in designer ??? no way!)

I have added fonts and I am able to select them in the editor, however they are not visible in the texregions unfortunately! The designer did show the font design in development setup, but at the customer premises text regions stopped working … :frowning:

I’m running out of options, what can I do to troubleshoot this further ? I’m loosing confidence from a good customer in this way!

I must admit, this topic is a bit chaotic :smiley:
I’ll assume that you did everything @cslaughter suggested?

Regarding CMS and fonts, did you do everything as described here? Especially the cache might be a problem it seems. - Fonts manual It shouldn’t matter from where you log in to the CMS if the fonts are installed then they should work.

Regarding Android devices, it might be a good idea to take a screenshot of status window on your device while it’s playing the layout with custom fonts which it can’t display.
Other than that as cslaughter said, you should enable debugging/auditing and see if there is something interesting in the logs.

I still suspect that all of this has more to do with permissions and/or server settings that anything else.

You can also try to sign up for a free CMS Instance trial with us, recreate/import your layout with custom fonts etc. and see if the issue persists.

how can I take a status windows screenshot (Did I mention) the upperbar is hidden right away in the new Android client, and I cannot get into the bar with mouse or keyboard!

What logs does support need to help me?

Action bar behaviour is set in display settings -> edit profile, on advanced tab you can change how it should be displayed.

Logs -> report fault page -> enable debugging -> recreate issue -> collect and save data

You might want to ‘censor’ any sensitive data that might be in this file before you upload it.

Action bar is timed in CMS 15 seconds, but the 1.7 v55 clients do not follow these settings :frowning:
I tried several times , I suspect there is something very wrong in my setup…

I will send a log, there is nothing to censor , this ius just some menu information from a restaurant :smile: smile:
hopefully this will help me in solving this

You need to tell the Minix not to hide the bottom bar automatically.

To get it back, click and slide up from the bottom edge of the screen. That will bring the bars back in to view. Then in the Android settings (not the Xibo for Android settings) turn off auto hiding that bar so it doesn’t keep happening.

XfA will hide the bar automatically as is required.

With regard to the text not showing, I presume you’ve already run Verify All on the modules screen in the CMS? It sounds like the files needed to render the text are missing from your CMS library so the Player can’t download them to show the content.

I will try to do this when Im on premises, Remoting in on Android is not an easy job… these minix x5 neo are not rooted , and I could not find satisfactory information how to proceed to root them!

Yes I ran Verify All modules (no errors?)

For reasons I don not understand : My setup choose \ip-adress\Xibo-Library/ for the library url
I can browse it locally in the network! but logs show that it is not
When transporting to the customer I had to change the IP…but I do not if this was sufficient?

Report logs show \\local-ip-adress\Xibo-Library/fonts.css) [function.fopen]: failed to open stream: No such file or directory

I have to correct permissions, but how deep?


Alex and Peter are by far the best to help you here over me. But since your were here not too long ago I would like to try and help.

This does not look right to me. I think that during the CMS installation that somehow the library media path was copied via network share instead of the local path. I would change the library path to the local path in the CMS under “Setting”, “Configuration”, “Library Location”.

For an example, My CMS on a Windows host is "C:\xibo_library" ( I am not using IIS, aka the Windows Web Server )

1 Like

Colin is absolutely right. Your CMS library shouldn’t be on a network share. It should be on the local drive of your server.

Your players should then have their own local libraries on their internal storage, or on an SD card, and the software will copy files from the CMS to the Players as they are required.

You shouldn’t be attempting to share the server library so the clients have some kind of access to it (over Windows file sharing).

On a Minix NEO X5 you can easily display the Xibo app menu by attaching a USB mouse and pressing the top left button on the IR remote control of the box, You can click the menu items with the mouse.

I’m setting it up, and having the same problem.
In status, I see a message "player is missing dependancies"
I installed from the APK, but the network did not have access to the internet.
version 1.7.57
Any clues, or should I just install an older Android Client?

I think I already replied to your service desk ticket, but just incase this is a different request.

First check the date/time are correct on the Player
Second check the Player has access to the CMS
Third run Verify All on the Modules page in the CMS. Allow the Player time to download any dependencies it’s missing and then it should start working.

Hi Have u solved this problem.

I am also facing the same problem .text scroll is not showing in android client.

Pls tell me if got some solution