Text not showing after installing latest Android R208

Hi,

After upgrading to latest android player from R206 to R208 the text, countdown timer and ticker stopped working. I tried all options like Verify all for modules, rebuilt the apk but now luck. However if i install R206 it works good and able to see the text. Can someone please help me with this issues.

Please find my environment details below,

1). CMS : docker version installed in AWS
2). Android Players,
Tried with MiBox4, Rooted T95 and even Android Emultor. None shows up the text. I have made a very simple layout of just one text widget to test these. Appreciate all your help and support.

Thanks and Regards,
Palani Ravindran

You need to run “Verify All” from the Modules page of your CMS, and then allow time for the updated files to download, and for your Player to restart the layout.

If those files are missing, most widgets won’t work at all.

Thanks Alex. I tried that but no luck. In fact i dont see the download is triggered after “Verify All” is clicked unliked the layout changes. I did a Android logcat and see though i set my embedded webserver to a different port to avoid port conflict error I see the below errors,

“2020-11-19 13:13:06.539 10181-23756/com.signage.wdhhohjwxx E/XFA:DisplayManager: HeartBeatEvent: Local Web Server isnt running. e = CLEARTEXT communication to localhost not permitted by network security policy
2020-11-19 13:13:06.554 10181-23756/com.signage.wdhhohjwxx E/XFA:DisplayManager: startWebServer - cannot start webserver: bind failed: EADDRINUSE (Address already in use)”

Please suggest.

Thanks and Regards,
Palani Ravindran

Also Just tried to use the cloud CMS to make sure my docker instance had any issues. Even from the cloud instance the Text, Countdown widgets did not work. I tried Verify All for modules as well.

Please find the log errors from the Player below,

XFA:WebView onReceivedError: http://localhost:9797/6_12_12.html, Code = -1, Description = net::ERR_CLEARTEXT_NOT_PERMITTED

Thanks and Regards,
Palani Ravindran

That makes sense thanks.

I presume you’re on Android 9 or 10? Assuming so, it’s a known issue that we discovered this afternoon. You’ll need to downgrade to R206 until we have a fix available. Apologies for the inconvenience.

No worries. Thanks a lot Alex. Yes you are correct, I have tested with Android 9 and 10 both. I Will downgrade for R206 for now and await next release. Thanks a ton for your quick support on this.

Thanks and Regards,
Palani Ravindran

1 Like
The Xibo Community site uses cookies. What are cookies?