Switching to docker - 1.7.9 to 1.8.0 upgrade

In the upgrade instructions it says to copy Xibo library files to shared/cms/library. What is the default location of the library files in 1.7.9?


Here you can find upgrade instructions - http://xibo.org.uk/manual-tempel/en/upgrade.html

There is no default location in 1.7.9. It will be whatever location you have configured.

You can see in the CMS Settings page.

So by “library” this is referring to the Media library? Or the lib folder in 1.7.9?

I am having issues trying to get my old layouts, campaigns and media files to show in the latest version of Xibo.

My system is Ubuntu 17.04

Here are the steps I performed to build the new version of Xibo:

I placed the old 1.7.9 Media Library files in /shared/cms/library

I exported the old database to a file named import.sql and placed it in /shared/backup

I then extracted the new 1.8.1 files into my install directory.

Once everything was backed up I ran sudo docker-compose up -d

Is there something I missed? Is there a log file I can access?


My import.sql was renamed to import.sql.done after I ran the docker-compose command.

Here is the docker-compose log output

cms-web_1 | Waiting for MySQL to start - max 300 seconds
cms-web_1 | MySQL started
cms-web_1 | Attempting to import database
cms-web_1 | Importing Database
cms-web_1 | ERROR 1062 (23000) at line 43 in file: ‘/var/www/backup/import.sql’: Duplicate entry ‘1’ for key 'PRIMARY’
cms-web_1 | Configuring Database Settings
cms-web_1 | Setting up Maintenance
cms-web_1 | DBVersion
cms-web_1 | 131
cms-web_1 | Updating settings.php
cms-web_1 | Configuring Backups
cms-web_1 | Configuring Maintenance
cms-web_1 | Running maintenance
cms-web_1 | Starting cron
cms-web_1 | Starting webserver
cms-web_1 | AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using Set the ‘ServerName’ directive globally to suppress this message
cms-db_1 | 2017-04-18 23:47:29 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
cms-db_1 | 2017-04-18 23:47:29 0 [Note] mysqld (mysqld 5.6.36) starting as process 1 …

I am looking into a fix for the database import error above.


I solved this by deleting the DB folder that was created when I first installed 1.8.0 and re-uploading import.sql

FYI half of the imported layouts were added as templates.

You might be wise to remove your 1.8.0 install, and upgrade straight from 1.7.9 to 1.8.1 as there were a bunch of upgrade issues resolved in that release.

That’s what I ended up doing. I had a bit of confusion because I wasn’t aware the old 1.8.0 database was being left behind after I executed the docker-compose down command.

I’m glad that sorted it. The database will be left when you run down otherwise you’d loose your data on an upgrade :slight_smile: