Stuck at login screen - proxy issue?

I just completed a fresh installation of Xibo today on a new installation of Ubuntu 16.04 Desktop.

From the host machine, I can reach the login page by navigating to http://localhost.
When I enter the default username and password, it spins at “waiting for localhost” forever.
If I type in the wrong password, it fails right away.
If I connect to the CMS from a different machine, I experience the same behavior.

From the host machine, if I disconnect the wired ethernet connection, I am able to log in properly.
If I reconnect the wired connection after logging in, I can navigate the CMS while as expected, but if I log out, I can’t log back in with the active network connection.

The computer is behind corporate proxy with no authentication.
I configured environmental variables in Ubuntu for proxy.
I configured Docker for the proxy.

I suspect this is a proxy configuration issue, but I don’t know where to look since it’s such a weird issue. In ubuntu, apt-get works. From docker, the Xibo CMS is reachable from other hosts.
I can reach the internet from the host machine, and can reach the CMS login page from the host machine and other machines, but just can’t get past the login page with an active network connection.

Can you confirm that localhost is in the local proxy exceptions list?

If http://localhost is not in the exception list, the proxy server may try to access itself rather than the CMS.

Many Thanks.

In Ubuntu, I manually configured the proxy address in network settings. I don’t see a way to configure exceptions in the GUI in Ubnutu 16.04

I also have the following entries in /etc/environment


For Docker, I have the following entries in /etc/systemd/system/docker.service.d/https-proxy.conf

Environment=“HTTP_PROXY=http://xx.xx.xx.xx:8080” “NO_PROXY=localhost,,*.xxx.corp”

I am new to Docker, and am far from a Linux expert, so I may be going about it the wrong way, or have something misconfigured. From the behavior, I suspect that the Ubuntu client is configured to work with the proxy properly, but the the Xibo cms/docker container is trying to reply through the proxy, instead of bypassing it, but I don’t know how to confirm that, or correct it.