SOLVED: Xibo docker install SQL problem - SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed

To be completed by the original poster:

CMS Version 3.3.3

Installation Method


Operating System



After trying an upgrade without luck, I tried to rollback.

After restoring the old files and trying to start the installation, it gives me “Fatal Error - sorry this shouldn’t happen.
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Try again” in my browser.

When I check the logs, I see the following:

cms-web_1 | Configuring Database Settings
cms-web_1 | ERROR 2005 (HY000): Unknown MySQL server host ‘mysql’ (-3)

I found a topic that also has this problem, but it’s on windows. Xibo CMS unable accessing mysql docker instance

Can anyone help me with this? Or at least point me in the right direction?

Thank you so much!

Kind regards

I found some more post regarding this problem. I am now trying the solution given here:

If anyone still has a better idea, please let me know!


The solution I tried did not work. Does anyone else have a solution for me?

I solved my problem by adding the following to my cms_custom-ports.yml

- mysql

1 Like

Sorry, I’m not a regular user of this forum and missed your question.

Actually I also just did an update again and it works perfect with this changes. I hope they do update the docker config sometimes