[Solved] Stuck on splash screen - Linux client 1.8-R3


I’ve install Xibo linux client 1.8-R3 through “snap” on Ubuntu 18.04.3 LTS.

I’ve a working client under Windows, so layout is ok. I’ve correctly set the Display profile to linux for the player. Layout is very light (6 Mo).

When i launch xibo-player option, i fill all option and it say : Display is active and ready to start.
When i click on “Launch client” xibo player option close and nothing happen.
When i start xibo-player it start but stay on the splash screen.

I don’t find the log for the linux client.

I’ve see that files in the local folder of Ubuntu are not exceed 284 bytes (.otf, .ttf, .mp4, .jpg, .js, .css).
I’ve set chmod 777 on that folder and files but same issue.

Do you have any idea ? I don’t know where to find more log or info


1 Like

Thank you for your message and welcome to the Community. Can you confirm what version of Xibo CMS you are using?

It’s possible that the Player is showing the Splash screen as it has not yet downloaded the required files to display the Layout you have scheduled, or the Default Layout you have set. If you have not scheduled a Layout or set a Default Layout, then it is expected that the Player will simply show the Splash Screen.

A good way to locate a Display is to open the Xibo Player Options again on your Ubuntu machine and click the Advanced tab. You will see an entry named Display ID. This is the unique identifier for that Player which ensures a new entry is created in your CMS. You could make a note of that ID, return to your CMS Displays menu option and click the button at the end of each entry. Choose the Edit option to open the Edit Display window. If the Display ID matches the Hardware Key for that Display entry, this is the entry for that Player.

Can you provide a screenshot of the entry for the Display? I would be interested to see what the Columns named Status, Authorised and Logged in state.

Many Thanks.

Thanks for your quick reply.

CMS Version is : Version 2.1.0

Splash screen is now display for a lot of time, the strange thing that the files in the local ubuntu client folder are freeze to 284 bytes.

I check the display hardware key like you said and find the correspondant display on the CMS, please find below the screencapture :

Thank you for the screenshot, this is indeed quite unusual. Can you confirm the types of media in your Layout?

When you start the Xibo for Linux Player, you should also have a Terminal open automatically that will log any errors, can you check for this terminal and confirm of you see any errors? Please note that closing the Player can also close the terminal, you may need to hold the Alt button and click the tab key to display the terminal on top of the Player, or alternatively minimise the Player to also reveal it.

Many Thanks.

For media type it’s an mp4 :

For terminal that open in same time with xibo-player i only have :

[18:15:52.176] [009027] [debug]: ScreenSaver is suspended : 1750813557
[18:15:52.176] [009027] [debug]:

I notice xibo-client will close after a delay but terminal doesn’t log more info than the two line from above.

This is a fresh Ubuntu install. Only install snap and xibo-client.

Thanks a lot for your help

i am also experincing this with the 2.1 CMS + 1.8R3 Client. Some terminal output attached.

also get [SOAP] Stream truncated after a few minutes

Thank you both for the information on the issues you are experiencing. I would be interested in testing your Layouts on my own Xibo for Linux Player to see if I encounter the same issues. If possible, can you provide a download link for the exported Layouts in a Private Message please?

Many Thanks.

Thanks for your support, i just send you a private message with the layout.

To keep you inform.

I try to use Xibo Cloud, and i have the same issue, player is stuck on start screen.

Downloaded files = 284 bytes.

Thank you for the update on the situation and the Private message, I will answer your questions from the PM in the main thread so other members of the Community can see should they find themselves in a similar situation.

I was able to Display your Layout without issue on my own Xibo for Linux Player, which is running 18.04.3 LTS. At this point, I would recommend:

  • Uninstall your Player.
  • Updating Ubuntu using the sudo apt-get update command.
  • Go to the directory you set as your Local library and make sure to delete any files that remain.
  • Go to the snap directory and make sure to remove the xibo-player folder.
  • Now install the Player again using the command
    snap install xibo-player --channel=stable
  • Open the Xibo Player Options application and enter the credentials for your CMS. Click save when complete. Once you have received the confirmation message that it is connected to your CMS, click the Exit button to close Player Options.
  • Now start the Player using the Xibo Player application tile or using your Terminal. Do not use Player Options to launch Client

Can you now confirm if the result is different?

Many Thanks.

1 Like

Can I check in on this subject too?!

I also have the same problem. CMS: 2.1.2 and the latest stable Linux player on Ubuntu 18.04 (up 2 date).

I have folowed DanBW’s instructions, but still have the same problem. CMS tells me all files are downloaded, but on the player nothing happens.

All downloaded files show as about 465 / 468 bytes.

After opening one of the mp4 files downloaded on the player with a text editor, the file seems to be a html document, not a movie file.

It tells me 301 Moved Permanently.

— Below the output of the file (I have replaced my domain with “mydomain.com”.

<title>301 Moved Permanently</title>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://mydomain.com/xmds.php?file=3d026e9488ae307df438cf975d6f3db5ae4fae701b26b198b5c430027ee96d31&amp;displayId=334&amp;type=M&amp;itemId=75">here</a>.</p>
<address>Apache/2.4.29 (Ubuntu) Server at mydomain.com Port 80</address>


Just a little update from me.

I was running my server on https. My apache config forced https, the xibo cms was not enforcing https, as this created too many redirects.

I changed my apache config to also allow http traffic, changed the xibo client to use http instead of https and deleted the whole xibo library on my player.

I then started the client again and now everything works like it should. Files downloaded correctly and my player is now playing.

Can it be that the player is trying to download the files over http, not https? Although the setting in de xibo player was to connect to https.

If I can help with some more debugging, please let me know. I would like to run everything over https.

Thank you in advance.

Hello DanBW,

Sorry for late reply i was on vacation.

I try what you said and it’s working.

Do you have an idea why ?


Thanks for the reply Sbstn_Lu. No need to apologise, I hope the vacation was a good one!

It’s great to hear that following my instructions has helped to resolve the issue. There are a few possible explanations as to why this helped. One possibility is that there were some required updates to Ubuntu that the Player required that have now been installed, resolving the issue. Another possibility is that it may have been linked to a bug that can occur if you use the Launch Client button in the Player Options application. Either way, it’s really great to hear you’re now up and running.

Many Thanks.

I have another PC where xibo-player not working, i’ve follow your instruction but still not working.

I’ve see on xibo-player log (in temrinal) : Download error - 404 Not found.

I’ve been able to solve this issue by deleting the display in Xibo CMS server, and authorise him again.

EDIT: I see that my xibo-player is in 1.8-R4 now.

Many thanks DanBW :smiley: