[Solved] Replace Media, Image issues 2.2.1

Hi there,

we’ve had an issue with the layouts publishing to the players since we’ve upgraded to 2.2.0. First I thought it had to do with the dimensions and resizing issue that is fixed in release 2.2.1 but we still do experience it. The image dimensions are 2339 × 1653 and it doesn’t show up red on the layout plan. It does work if the size is reduced (1637 × 1157 is working fine right now).

The players will permanently try to fetch the new layout failing to do so.

It’s okay for me to scale the images down for now but what really reduces usability is that it seems the replace feature on the media tab has disappeared completely. I’ve used that feature daily to change a picture each morning. Looks like the only option now is to upload a new pic, delete the old one, checkout the layout add the image change the duration and save it all rather than simply replacing that single file without touching the layout at all.

Is this intended or will be see a revival of that feature?


Welcome to the community!

The resizing issue should be fixed in 2.2.1, the the image in question was broken in 2.2.0 the you will need to run a task to fix that. Please refer to the Release notes and how to ‘Repair existing corrupted images’. You will also need to make sure that XTR is running and the Image Processing task is not in an error state.

With regards to the Replace functionality, that is still available. Replace images from the Media tab using Edit:

or by Editing the Image Widget form on the Layout:


Hi Natasha

thank you for the quick reply. Could you please let us know how we check for XTR and the state of that task? I’m not too familiar with the system.

As for the replacement of images, I’ve cleared the browsers cache and cookies and now it appears through the menu again. This is how it looked before, so I’m glad that feature is still in place.

Thank you

If you go to the Tasks page from the main CMS menu you can check the last run status and time of those tasks.
If ‘Last Run’ is empty, or more than a few minutes ago, then XTR isn’t being run. If the status is a X then it is in an error state.
Also check to see if Active is ticked for Image Processing.

Hi Natasha

thank you so much, I had to delete the media cache task and create it again, it did ran through as expected and now it’s all back to working as intended.

All solved, appreciate the fast reply and useful instructions.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.