Small problem with RSS Ticker and stock module

I’m currently moving to the lastest version of CMS 1.8.8 and having some difficulty running Stock Modules and Ticker.

My current production server is running on 1.7.9 and i’ve decided it was the time to upgrade. I’ve started a new VM. I’m running on a Centos 7 and installed sucessfully CMS 1.8.8.

I’ve redid my layout and my stock and rss module wont work.

Here is the error from the log:

2666 15e9f5e 2018-04-12 15:09 WEB GET ERROR /playlist/widget/tab/results/9 Problem getting stock information. E = cURL error 60: Peer’s Certificate issuer is not recognized. (see

2663 69ff062 2018-04-12 15:07 WEB GET ERROR /playlist/widget/resource/4/6 Unable to get feed: Client error: GET resulted in a 407 authenticationrequired response: <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “” (truncated…)

Unable to get feed: Client error: GET resulted in a 401 authenticationrequired response: <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “” (truncated…)

I’m running behind a proxy. If i set my proxy the same way i did on 1.7.9 in the network setting, my weather module wont work. As for the RSS, proxy on or off i get 401 or 407 authenticationrequired.

any idea how to solve this?

I assume that’s non-docker installation?

Seems to be curl certificate issue - Using Tickers, Forecast, Twitter and other external resources that make use of HTTPS connections

The feed itself is working fine on 1.8.8.

yes, it is non-docker installation. Since Forecast work… it must be http ? Stock and Tickers https ?

Your proxy server is asking for authentication. In addition, it looks like it does a man-in-the-middle inspection of SSL certificates, so you’ll need to either:

Give Xibo a username and password to authenticate with the proxy if it supports HTTP Basic authentication


Put in place an exception on the proxy to allow Xibo CMS’s IP to access the proxy without authentication


You’ll need to add your proxy’s root CA that it’s using to fake it’s SSL certificates in to your system SSL certificates so that the fake certificates the proxy is issuing are accepted.

I was able to bypasss the proxy and everything work now. Thank you Alex.

1 Like