Setup library location on a NAS?

I’m trying to setup the library location to be located on a NAS drive (Synology in this case). The main reason is to keep the data storage off the hard drive of the serving PC. But, for some reason it doesn’t allow that to occur. I’m guessing it’s probably ID (ie: name, user, password) or something that is being passed to the NAS and it’s rejecting the connection.

I’ve tried it by using the NAS full path as well as mapping it as a network drive (Windows 7). In all cases, it simply isn’t allowing it. I’m able to do any file accesses from Windows Explorer though so I know I have the permissions setup. So, I think I need to know how to tell the CMS to include username and password info for the NAS or simply not send any username or password info.

I can successfully redirect the library to anywhere on the main hard drive, but not to the network location.

Any thoughts?

The CMS library should be local to the machine running the CMS.

If the CMS software cannot access the library because of a network error or the NAS going down then it will cause real problems.

You need to have both on the same computer.

Well, that’s not really the answer I wanted to hear. I don’t have a ton of hard drive space to allocate on the machine I loaded the CMS on. A NAS going down and thereby causing a digital sign not to work is a “don’t care” in my book. The NAS going down is a bigger issue needing my attention. If the network didn’t work and the sign didn’t update, that might be an expected issue also.

So, either of those areas causing is issue would be an understandable side effect of the system architecture and something I’d be willing to live with. You seem to be implying (by saying real problems) that it might crash things (corrupt the database). That is unfortunate. Given that is is an open-source project/system, I guess I’ll have to live with the limitation.

I’m still not understanding why it didn’t accept the location though. How would the system know (via mapped drive) that the drive wasn’t actually local?


Xibo itself doesn’t know.

I’m not saying you can’t put it on a NAS, I’m telling you it’s not a recommended or supportable configuration. You are completely free to do as you wish.

I suspect the user your webserver is running as isn’t the same user as you are logged in to Windows as, and so it doesn’t see the same drive mappings as you do. You’ll need to either ensure the drives are mapped for the user the webserver is running as, or change the user the webserver runs as to the user you’re logging on as.

I do appreciate the info. I am trying to find a way to shift some stuff around to follow the recommendation.