Server error 500 all of a sudden


#1

My website worked perfect for a long time and I haven’t updated it yet. (thinks it is version 1.6.2, but can’t access it at the moment) But since a few days I get Server Error 500 when trying to enter the CMS.

I already searched for answers, but could not find it. Did find the way to expose my errors, because it would only give me a blank screen when trying to access the site.

These are my errors:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringReader has a deprecated constructor in /home/end21/domains/customtemplates.nl/public_html/plus/3rdparty/php-gettext/streams.php on line 48

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; FileReader has a deprecated constructor in /home/end21/domains/customtemplates.nl/public_html/plus/3rdparty/php-gettext/streams.php on line 84

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; CachedFileReader has a deprecated constructor in /home/end21/domains/customtemplates.nl/public_html/plus/3rdparty/php-gettext/streams.php on line 145

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; gettext_reader has a deprecated constructor in /home/end21/domains/customtemplates.nl/public_html/plus/3rdparty/php-gettext/gettext.php on line 36

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/end21/domains/customtemplates.nl/public_html/plus/modules/module_db_mysql.php:31 Stack trace: #0 /home/end21/domains/customtemplates.nl/public_html/plus/lib/include.php(112):
database->connect_db(‘localhost’, ‘username’, ‘password’) #1 /home/end21/domains/customtemplates.nl/public_html/plus/index.php(24): include_once(’/home/end21/dom…’) #2 {main} thrown in /home/end21/domains/customtemplates.nl/public_html/plus/modules/module_db_mysql.php on line 31

I did take out my username and password, since these would give anybody access to parts they shouldn’t. :wink:

I would love to have access again, so I can at least export my layouts and import them back in a new version 2 Xibo install. So if these errors can’t be resolved, I would love to know how to get my layouts. :wink: