ScheduleManagerThread Agent threads are dead, not updating status .json


#1

I’m getting this message on my Windows 10 clients.

Running 1.79 on CMS and client. The default layout shows, but when I schedule a layout, either from the layout ->Option->schedule now, or the main schedule screen, the client shows this error.

Have restarted CMS server (Redhat 7.2) and client.

Any help is greatly appreciated.


#2

We might need to see a screenshot of status window on your device and CMS logs.

For CMS logs, please go through Report Fault page (enable debugging, recreate the problem, collect logs).

Troubleshooting.txt may contain some sensitive data, please check it before uploading it here (or send it to me via pm).


#3

Here you go.

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#4

Sorry, here’s the log dump after turning on debugging.

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#5

You will need to upload this log file somewhere dropbox/googledrive and share the link with us, as I mentioned may contain some sensitive data, please check it before uploading it here (or send it to me via pm).

When you replied via email with it attached, I guess discourse didn’t like it, since there is nothing here.


#6

Ok, here’s the log file:

Environment Checks

Item Status Advice
PHP Version PHP version 5.3.3 or later required. Detected 5.5.38
File System Permissions Write access required for settings.php and install.php
MySQL database (PHP MySql) MySQL support must be enabled in PHP.
MySQL database (PDO MySql) PDO support with MySQL drivers must be enabled in PHP.
JSON Extension PHP JSON extension required to function.
SOAP Extension PHP SOAP extension required to function.
GD Extension PHP GD extension to function.
Session PHP session support to function.
FileInfo Requires PHP FileInfo support to function. If you are on Windows you need to enable the php_fileinfo.dll in your php.ini file.
PCRE PHP PCRE support to function.
Gettext PHP Gettext support to function.
Calendar Extension PHP Calendar extension to function.
DOM Extension PHP DOM core functionality enabled.
DOM XML Extension PHP DOM XML extension to function.
Mcrypt Extension PHP Mcrypt extension to function.
Allow PHP to open external URLs You must have allow_url_fopen = On in your PHP.ini file for RSS Feeds / Anonymous statistics gathering to function.
DateTimeZone This enables us to get a list of time zones supported by the hosting server.
ZIP This enables import / export of layouts.
Large File Uploads Support for uploading large files is recommended.
Internationalization International Support for formatting Dates, Numbers, etc.
cURL cURL is used to fetch data from the Internet or Local Network

LOG Dump
Date,Page,Function,Message

Display Dump
DisplayID: 2
Display: DAWSON2NDCP1
Default Layout: 169
Logged In: 0
Last Accessed: 1473969879
Interleave: 0
Licensed: 1

DisplayID: 3
Display: PC43
Default Layout: 0
Logged In: 1
Last Accessed: 1475603939
Interleave: 0
Licensed: 1

Settings Dump
Setting: MEDIA_DEFAULT - Value: private

Setting: LAYOUT_DEFAULT - Value: private

Setting: defaultUsertype - Value: User

Setting: userModule - Value: module_user_general.php

Setting: defaultTimezone - Value: Africa/Abidjan

Setting: mail_to - Value: mt@uga.edu

Setting: mail_from - Value: xibo@fcs.uga.edu

Setting: jpg_length - Value: 10

Setting: ppt_length - Value: 10

Setting: swf_length - Value: 10

Setting: audit - Value: audit

Setting: LIBRARY_LOCATION - Value: /xibo-library/

Setting: HELP_BASE - Value: http://www.xibo.org.uk/manual/en/

Setting: PHONE_HOME - Value: On

Setting: PHONE_HOME_URL - Value: http://www.xibo.org.uk/stats/track.php

Setting: PHONE_HOME_DATE - Value: 1475161032

Setting: SERVER_MODE - Value: Production

Setting: MAINTENANCE_ENABLED - Value: Off

Setting: MAINTENANCE_EMAIL_ALERTS - Value: On

Setting: MAINTENANCE_KEY - Value: changeme

Setting: MAINTENANCE_LOG_MAXAGE - Value: 30

Setting: MAINTENANCE_STAT_MAXAGE - Value: 30

Setting: MAINTENANCE_ALERT_TOUT - Value: 12

Setting: SHOW_DISPLAY_AS_VNCLINK - Value:

Setting: SHOW_DISPLAY_AS_VNC_TGT - Value: _top

Setting: MAINTENANCE_ALWAYS_ALERT - Value: Off

Setting: SCHEDULE_LOOKAHEAD - Value: On

Setting: REQUIRED_FILES_LOOKAHEAD - Value: 172800

Setting: REGION_OPTIONS_COLOURING - Value: Media Colouring

Setting: LAYOUT_COPY_MEDIA_CHECKB - Value: Unchecked

Setting: MAX_LICENSED_DISPLAYS - Value: 0

Setting: LIBRARY_MEDIA_UPDATEINALL_CHECKB - Value: Unchecked

Setting: USER_PASSWORD_POLICY - Value:

Setting: USER_PASSWORD_ERROR - Value:

Setting: MODULE_CONFIG_LOCKED_CHECKB - Value: Unchecked

Setting: LIBRARY_SIZE_LIMIT_KB - Value: 0

Setting: MONTHLY_XMDS_TRANSFER_LIMIT_KB - Value: 0

Setting: DEFAULT_LANGUAGE - Value: en_GB

Setting: TRANSITION_CONFIG_LOCKED_CHECKB - Value: Unchecked

Setting: GLOBAL_THEME_NAME - Value: default

Setting: DEFAULT_LAT - Value: 51.504

Setting: DEFAULT_LONG - Value: -0.104

Setting: SCHEDULE_WITH_VIEW_PERMISSION - Value: No

Setting: SETTING_IMPORT_ENABLED - Value: 1

Setting: SETTING_LIBRARY_TIDY_ENABLED - Value: 1

Setting: SENDFILE_MODE - Value: Off

Setting: EMBEDDED_STATUS_WIDGET - Value:

Setting: PROXY_HOST - Value:

Setting: PROXY_PORT - Value: 0

Setting: PROXY_AUTH - Value:

Setting: DATE_FORMAT - Value: Y-m-d H:i

Setting: DETECT_LANGUAGE - Value: 1

Setting: DEFAULTS_IMPORTED - Value: 1

Setting: FORCE_HTTPS - Value: 0

Setting: ISSUE_STS - Value: 0

Setting: STS_TTL - Value: 600

Setting: MAINTENANCE_ALERTS_FOR_VIEW_USERS - Value: 0

Setting: CALENDAR_TYPE - Value: Gregorian

Setting: DASHBOARD_LATEST_NEWS_ENABLED - Value: 1

Setting: LIBRARY_MEDIA_DELETEOLDVER_CHECKB - Value: Unchecked

Setting: USE_INTL_DATEFORMAT - Value: 0

Setting: PROXY_EXCEPTIONS - Value:

Setting: CDN_URL - Value:

Sessions Dump
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
RemoteAddress: 128.192.32.240
Session Data
pagename|s:5:"admin";token|s:32:"71bce6ac12949492f39554bbff78a044";token_timeout|i:1475603912;message|s:0:"";userid|s:1:"3";username|s:4:"mark";usertype|s:1:"1";DisplayGroupIDs|a:1:{i:0;s:2:"12";}57f3ea9608dde|s:32:"23998c273b58fdf13cf0accb9bf5fc98";57f3ea9608dde_timeout|i:1475603094;

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#7

Another try – this is only 58K so it should pass any gateway.

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#8

Hey Peter, I just turned the firewall off on the player, and content is being downloaded and displayed! So, what ports should be opened on the player??

Thanks!

Mark


#9

Belay that. :frowning: It worked for a single layout, but the next one no show, and the Info page shows the same ‘Agents are dead’ error. Something’s keeping the download agent from completing its task.

sigh


#10

What firewall / anti virus do you have installed there?

Do you use anything else that could interfere/block the connection?

Is player running on an account with admin privileges?

Could you try to set the local player library to the default one ie
C:\Users\USERNAME\Documents\Xibo Library

Just to be sure please also check the CMS library in CMS settings, it should be fully qualified path there, please see Library location section of this post - Xibo CMS Post-Installation Setup Guide

It seems odd, because all content seems to be downloaded, but for some reason it’s still blocked.


#11

[Image removed by sender.]

Peterhttps://community.xibo.org.uk/users/peter staff
October 6

What firewall / anti virus do you have installed there?

Windows Defender – but turned it off to test. Also turned off firewall and it seemed to work, but then stopped.

Do you use anything else that could interfere/block the connection?

No.

Is player running on an account with admin privileges?

Yes.

Could you try to set the local player library to the default one ie
C:\Users\USERNAME\Documents\Xibo Library

Just to be sure please also check the CMS library in CMS settings, it should be fully qualified path there, please see Library location section of this post - Xibo CMS Post-Installation Setup Guide

It seems odd, because all content seems to be downloaded, but for some reason it’s still blocked.

Ok, I totally removed the client program, removed all client library files, moved the library and set the CMS to point to the new library. Turned off Defender and tried another 1.7.9 install on the client. I get the attached error, although that probably has little to do with my previous issues. I have Powerpoint 2010 installed BTW.

Visit Topichttps://community.xibo.org.uk/t/schedulemanagerthread-agent-threads-are-dead-not-updating-status-json/7334/10 or reply to this email to respond.

To unsubscribe from these emails, click herehttps://community.xibo.org.uk/email/unsubscribe/bed6fd022fffb3f5ba42e489a92d7d77995f022506633e5ddc9f8b401e0d51bb.


#12

Yeah, there are at least two topics at the top with the same issue.

You can ignore that error and make those registry changes manually after installation.

Here, under Prepare your Windows player:
http://xibo.org.uk/manual/en/media_module_powerpoint.html

While there was no new version of this client, the current Xibo for Windows 1.7.9 that you can download from here will not give this error.


#13

Still getting the ‘agent threads are dead’ error – no matter what I do, nada. :frowning:

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#14

Woot! I believe I’ve resolved the issue Peter. For some reason, the Profile was not set for Windows and even though there’s only an Android and a Windows profile, they were both set as ‘default’.

???

Mark Toomey, Systems and Network Manager
Family and Consumer Sciences, UGA
mark at fcs dot uga dot edu: GChat: mark@toominator.netmailto:mark@toominator.net
Owner: USG-TECH, USG-VM, HT, COOLTECH,& UGASTUFF Lists
voice:706-542-4738 - cell:706-255-8683 - fax:706-542-4168
Linux: The Power of Choice


#15

I’m not sure if that was the problem.

By default there are Windows and Android profiles and both are set as default, because they will be assigned by default to their corresponding device type (Windows to Windows player, Android to Android player).

So when in display settings you had empty record in display profile it was actually the Windows profile (default).


#16

I’m having this issue too.
I can’t tell if the error is the cause, but it’s the only consistent error with the displays that are suddenly showing only a black screen.