RSS feed images not visible

With Xibo 1.7.9. RSS feeds don’t display images.
Setup the option ‘image overlaid with the feed content on the left’ but only the text and no images…

Maybe permission error?

Could you please share the rss feed link with me?

Hi Peter,

Feed url:

Ok, it shows the images for me with just the ‘Image overlaid with the title’ and ‘Image overlaid with the feed content on the left’ templates.

So, you might want to go to Report Fault page, enable debugging, recreate the issue (reload layout with this feed / create new ticker with this feed etc) then check Logs page for any errors, there should be something there that will clarify the situation.

Hi Peter,

Thanks, only receive this into the error log:

4485 16-12-13 12:12:22 CMS ticker GetRssItems Namespace: image. Tag: Link.
4484 16-12-13 12:12:22 CMS Layout AddLk Returning existing lkLayoutMediaId 202

4467 16-12-13 12:12:22 CMS module SetMediaInformation Existing Assigned Media XML is: \n <?xml version="1.0"?>





4570 16-12-13 12:14:35 CMS module Loading SimplePie to handle RSS parsing.

right, did you try to schedule this layout to a player?


Fellow Dutchman here. I am also trying to get RSS feeds with images to show properly through Xibo. This does not seem to work. Currently running 1.7.9 and tried with and

Both ‘Image overlaid with the title’ and ‘Image overlaid with the feed content on the left’ only show the text.

I have enabled debugging and watched the log after reproducing the problem. Nothing shows up over there…

Regarding nasa feed, it will take time to download the images, as they are rather high quality.

As for your other rss feed, I’ve just tried it and it did display the images without any issues for me - on my local dev CMS (1.8.1) as well as in our Cloud (1.7.9, 1.8.1).

The feed itself is valid and it does work in Xibo as well, it will be something in your server configuration that is preventing the images from being downloaded, there should be some information about it in the logs or even in browser console if those images aren’t loaded in layout designer.