Release 4.0.0 not found after Upgrading from 3.3.7 to 4.0.0

Hi Xibo Team ,

after upgrading my docker intallation from 3.3.7 to 4.0.0 as usual, the Error Message came up:

docker-compose up -d
Pulling cms-web (Package xibo-cms · GitHub)
Pulling repository Package xibo-cms · GitHub
ERROR: Error: image xibosignage/xibo-cms:release-4.0.0 not found

And then nothing worked, so i rolled back to 3.3.7.

I do not know whats the problem…

Thank you, yours Mark

Hi Mark,

This would seem to indicate that your image name in the docker-compose file is xibosignage/xibo-cms:release-4.0.0 instead of Can you check that and see?


Hi Dan,
i think it is correctg, the compose file is like this:

Yours Mark

Yeah, that looks right.

What happens if you run this on a command prompt:

docker pull

Well I am a bit lost here!

@alex any ideas?

Perhaps a proxy or some kind of firewall blocking access to the repository.

If i pull 4.0.0 they add “” at the beginning.
If i pull 3.3.7 it looks ok without “”, and already installed.

Maybe this is a hint on how to solve it?

Are you using a proxy server or a transparent proxy?

No i do not think so. To get to my site, you have to enter http://XX.XX.XX.XX:8080/ , that means the 8080 is obliogatory. Is this a problem?

The URL you use to access the site isn’t important here - it’s how your computer is talking to the internet.

The messages you have suggest that something is blocking your connection to the internet and that’s why it’s unable to download the image.

It is strange, because it always worked until 3.3.7 and i did not change anything on server configuration.

1 Like

I don’t have any other ideas I’m afraid. That’s what it looks like to me.

If it’s not that, then I don’t know why your server isn’t able to download that image. You could load it manually from another computer that does have access potentially.

The final tag we pushed to Dockerhub before switching to Github packages was release-3.3.3 ~ 5 months ago. Since then its all been in Github.

You can see the package shown in the Github UI here: xibo-cms versions · xibosignage · GitHub

Can you ping ?

Yes, al lot of sequences, i stopped it an 0%losses

Just a wild idea, can you pull the XMR container which is also hosted in GHCR?

This is the Image history, so ghcr worked before.

How about if you reference it by its SHA:

docker pull

If this doesn’t work then I am really out of ideas :smile: