Problems with second screen

Hi,

I set up a PC (Windows 10) with two clients for two 4K screens by following the given instructions of this forum.
I was able to configure both clients and to add both to the CMS.

But then, I encountered two problems:

  1. I set a profile for the second screen, so that the client aligned under the first screen. The offset is set on 2160, but the client either didn’t move at all or just disappeared. The same problem also still occurs when I set the width and height in the profile. How do I get the offset right? (Note: it also didn’t work with the screens being aligned horizontally)

  2. When I start both clients, they only run for about 15 seconds before one of them closes. I already renamed them, removed the watchdog or changed the process number in the watchdog config. No matter what, one of them still closes everytime. How can I change that?

I’m using the newest version of the client and the newest Docker version on Linux for the server.

The more detailed instructions for it are here - https://github.com/dasgarner/xibo-manual/blob/develop/source/en/install_windows_client_multiple.md

That will be in the manual in the next release as well.

Regarding the offset, if the second screen is below one main screen (in WIndows display Settings for extended desktop) then you will need top offset to be the same as height of the first screen.

If it is on the right of the main screen (in Windows display settings for extended desktop) then the left offset will need to match your main screen width.

Both profiles should have specified player size as well.

Thank you for the quick reply!

I managed to fix the offset problem by changing the scaling on Windows from 200% to 100%.

I went through the watchdog config again, but the second screen still keeps quitting after a short time.

There might be one more thing to change and we’ve forgot about it in the instructions, at least at the time when I mentioned the link, it is added now - I’m talking about Embedded Webserver.

Could you please navigate to the Displays Settings page -> Edit display profile assigned to your Second player -> Advanced tab -> Embedded Web Server Port

There will be port 9696, please change that to 9697 and save the profile

Then restart your player to make sure it picks it up - you can also navigate to the library location of your second player and open config.xml there is a line about the embedded server port, just to confirm that player is using 9697 now.

I believe that might fix your problem there.

1 Like

Yes, that worked for me!
Thank you so much, it works perfect now!

1 Like

Hi guys,

what regarding Dual Display on Linux Player?

The Xibo Community site uses cookies. What are cookies?