Problem installing Xibo for Docker on Windows 10 64 bit (CMS Containers)

Hello there,
I’m new to Xibo and I’m trying to set it up following the instructions here :

Everything goes fine up to the

docker-compose up -d

Here is what I get from PowerShell :

        Can't find a suitable configuration file in this directory or any
        parent. Are you in the right directory?

        Supported filenames: docker-compose.yml, docker-compose.yaml

Anyone can help me find out what I did wrong? Thanks in advance.

Welcome N3BUL4 to the Xibo Community!

The message suggests that you are not running the command from the same directory as your Docker install files. First I would make sure that you have used the cd command to move to the same directory as your yml files. Then try running the up command again.

If the issue persists, please confirm include a screenshot of the error/message you receive.

Many Thanks.

Alright I did what you said and another error showed up :

Is that the right directory?

Thanks for the screenshot. Your Powershell window suggests you’re not running it in Administrator mode. Can you try closing Powershell, then right click on it and choose Run as Administrator. Then cd to the directory and run the up -d command again. Once again if you encounter an error, please post a screenshot.

Many Thanks.

Upon further inspection, I found out I was not logged in on docker, which caused the previous error (same as previous post).
Here is what I get now :

Ok, alright, I found the problem : my containers were set to Windows containers.

Now, I have a problem similar to here : Xibo, docker, windows 10, failure - Fixed! Thank you Peter

I don’t plan on running SSL, which only leaves 2 ports : 80 and 9505.
I verified their usage through windows console, they’re both being used by Docker (com.docker.backend.exe), which seems fine to me. Is my problem the firewall or something else?

My apologies for the delay in replying to your messages N3BUL4. Excellent news that you have now managed to resolve the issues by logging into Docker and setting changing the Container settings from Windows to Linux.

I took a look at the Post you referenced, it sounds like the person installed then started their Docker containers but was unable to access their CMS on the localhost URL. Is this the issue you are experiencing? If it is, please note that after your containers are upped, it takes a short time for the CMS to become accessible.

Could you try running the docker-compose up -d command, then run docker ps -a to see if the containers are up and running. If they are, please wait for 10-15 minutes then try accessing the login page by entering the localhost URL. if you are still unable to access your CMS, please provide a screenshot of the docker ps -a response.

Many Thanks.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.