Powerpoint is not enabled on this display


I’m Daniel, I have installed Xibo CMS latest version 1.7.3 on Windows 2012 R2 OS & using Office2013. Whenever schedule a PPT for any display am getting the error: “Powerpoint is not enabled on this display”.
Can you please help to resolve it.

Go to Display settings in the CMS, choose the relevant profile, go to Edit and check the box where it asks if you want to enable powerpoint.

I’ve had issues with powerpoint so I convert them to WMV and show them instead.

Let me try that & update you

I am quite new to Xibo, when I try to upload the converted wmv format (8MB file) to CMS , am getting “file size not allowed, upload less than 2mb”

Now, I need to fix the max size & PPT not enabled issue. Please help in this

You can look at this guide in the “Large File Uploads” section:



I tried the changing the settings in Request filter of IIS & the configuration in php.ini

But am not able to upload files above 2MB, please help with this


I tried enabling ppt layout, still it doesn’t play in the player.


Please see here if you are still having trouble uploading files larger than 2MB.

@cslaughter: Thanks! that solved my issue of fixing the upload issue.

@executiverocker: The MS PPT converted to wmv format (video) works as charm, I am hopeful of fixing the “Powerpoint is not enabled on this display” issue.

Dear All,

Sorry for bothering again, I need to fix the “Powerpoint is not enabled on this display” with Microsoft PPTs in .pptx format.I appreciate your inputs.


Please go to Modules. Then Edit the PowerPoint Module. Please make your options look like this:

Now try to use the file again.

Thanks cslaughter that worked!

Thanks guys, now I am able to use PPTs in Xibo.