"please enter a from date" on schedule now?

(Full install server(non-docker) 1.8.6 on centos)

I have a bit of an issue here.
When my users try to “schedule now” they get an error message that states that they have to enter a from date.
I have tried this and have confirmed it.
It affects both layouts and campaigns. It worked like a charm in 1.8.5

Are you using schedule now with ‘always’? If so that’s this bug https://github.com/xibosignage/xibo/issues/1431

I’d highly recommend updating to 1.8.7, there were few nasty issues in 1.8.6 that we resolved in the newer version.

1.8.7?! What fresh madness is this?
I upgraded to 1.8.6 yesterday!

Oh well, i’ll get right on it.

Indeed the 1.8.7 was released not fully a week after 1.8.6 (it was released yesterday afternoon UK time), because the issues discovered shortly after 1.8.6 release needed to be addressed asap, therefore we decided to release new version that soon after the previous one.

I appreciate that it might not be ideal, as you need to perform an upgrade again, but I believe it is better this way with those 1.8.6 bugs fixed already.

Of course that will not become a standard we certainly do not want to make new releases every week, 1.8.6->1.8.7 was an exception.

I’m already done, with 100% success.

It’s funny, it was released an hour after i did the last one. :wink:

But i like it. It means the product is alive!


I’m glad to hear that!

Why there is no easy way to update.

If so, I do not know her. do I have to reinstall the entire cms?

If not it is the procedure

Thank you

I think that is because there is many ways to install it.
Personally, i upgrade mine in about ten minutes, with some backups.

Can you show me your procedure? not to get in trouble.


It really depends how you’ve elected to install it - if you’ve taken the time to understand docker then all you need to do is backup the shared folder, download the new docker-compose.yml file (or make a small modification to your existing file) and do docker-compose up -d.

If you’ve installed via another method - perhaps manually copying in the files, then all you need to do is rename your old folder, download the new archive in the old folders place and copy over your web/settings.php file.

Always take database and library backups of course.

see: https://xibo.org.uk/manual/en/upgrade.html

1 Like

And if you have made a custom theme, it’s important to remember to copy that as well.

1 Like