Player will not start

Hello everyone. I am having an issue trying to get the Linux player to work on Ubuntu 18.04. I have setup a vm with Ubuntu 18.04.3 and have installed the Linux player via snap. I ran the xibo-player.options and set the IP address of the CMS, set the key, etc. I then authorized the display and set the default profile to that of the Linux profile. (I had to update Xibo docker container from 1.8.9 to 2.2.1 currently) However whenever I run the xibo-player I get the following error in the terminal.

I don’t know what this means and am not sure where to go from here. Any help would be appreciated.

Hi jcyrusrti, thanks for posting and welcome to the Community!

The error you are seeing has also been seen by other users on Ubuntu 18.04 but was resolved by uninstalling the Player, then running the sudo apt update command to make sure your Ubuntu install is up to date, then reinstalling the Player again. Can you try this and confirm if the issue persists?

Many Thanks.

Daniel,

Thank you for your reply. I did find another thread that listed this as a fix for this issue. This was a fresh install with updates ran before I installed the snap player, however, I did uninstall and re-run sudo apt update and then reinstalled the snap player and it did fix the issue. I still got the same error message when starting the player from the command line for about 2 cycles and then the player started and connected to the CMS.

Thank you for your help.

This is great to hear, thank you for letting me know the issue was resolved after updating your Ubuntu install. I was hoping you might have seen one of the other posts, either way I’m glad you can now proceed with your Xibo for Linux Player.

Many Thanks.