No option for Shell Command

I’m using the cloud hosted CMS 1.7.7 and I don’t get an option to add a Shell Command to to a region timeline.

Following the documentation
And Here
I gather I should be able to add a shell command as a media type to a region time line, but it simply isn’t there. I’ve also searched high and low for a setting to enable Shell Commands as an option. No luck. Can anyone point me in the right direction?

My Android devices are rooted so they should work with Shell Commands.


If you look under “Modules” and edit Shell Commands, is the “Enabled?” box checked?

Yes it’s there and it’s listed with an X in the Enabled column, but there is no way to toggle this option. I can’t modify settings for any of these modules.

When I click the drop down menu I just get a small blank box with no options in it. Same for all lines, not just the Shell Command. Both Chrome and IE.

Try toggling the down arrow on the far right:

Clicking on Edit will then give you a pop-up that will allow you to enable the module:

Hope that helps!

If “Edit” doesn’t show up in the Drop down menu, that seems like an error of some kind. It works for me on Chrome just fine.

Sorry, was going to mention that I use Firefox, but forgot to put it in. I just tried it in IE 11 and it worked without any problem.

Thanks guys,
It definitely appears as though Edit isn’t showing up for me for some strange reason.
Just tried on a couple different computers and all I get is this:

btw It’s the same blank box under the drop down arrow for each feature under modules… with the exception of “Twitter Provider” where I do get the option “Connect to Twitter” in the drop down box for that particular line.

Is it safe to hit the Verify All button at the top of the modules page?


Although it will not solve your issue, looking at your CMS URL it seems you’re hosting with Spring Signage.

Could you please open new support ticket with them regarding this?
We’ll enable the shell command module for your CMS Instance,. but it would be better to do this through official channels so please create new ticket.

As for twitter, since you’re hosting with Spring Signage, it is basically configured for you, you don’t need api key for it (same for forecast)

Please read under ‘Xibo Cloud Users’

Submitted the ticket.