No data in remote datasets

Hello again

Ive got a problem with my remote datasets again - this time the data seems to have dropped out of some of my datasets so my charts are blank on my Xibo screens and this has been the case now for about 48 hours when Ive set them up to sync every minute. The displays that use these datasets are all logged in and it was all working fine for about a week and now, 1 by 1 I seem to be loosing the data out of my datasets and I dont know why. They arent syncing either and Im struggling to understand what triggers a sync - run now seems to have no effect either. The json files are full of data that the remote datasets use and the Test URL is working fine. Ive tried deleting my columns and readding them, making changes to my excel document so that the data changes in the json file, but still no data and no syncing, and the displays are all up and running… My Xibo windows task scheduler process is running fine…

Any ideas as to why this is happening? Screen shots below …

The last screenshot shows that the task is running, as are your Daily and regular maintenance, and email notification tasks.

Without knowing your timezone or how long ago the screenshots were taken I can’t say if that’s correct or not, but you would typically expect those task to run for a few seconds (as shown in Last Duration).

If they’re taking longer, then perhaps you restarted the server or something when they were mid-run? They’ll timeout after several hours and retry.

You’d expect to see a clock in the Status column once they have run.

Hi Alex

Thanks for the reply. I still have datasets that are being used by charts that are displayed on the clients 24/7 that have still not been synced since the 15th and have no data populated from the Json file that has data in it. My time is set to GMT+1 Europe, London. Are there any logs I can check to see why this might be happening? Its not good if I have to wait several hours for the timeout before it retries… These screenshots are taken now so thats 9.56am on the 18th… Im not sure why some appear to be syncing and some arent and the only time I see a clock in the status column is if I make the task ‘inactive’ - when I make it active again, it goes back to the cogs after a few seconds…

Marking as inactive and then enabling again effectively resets the task.

That it goes to a cog straight away means it is running, but clearly it’s not succeeding, and looking at the other tasks they’re having the same issues.

Please can you check the server over generally - disk space issues? Out of memory that kind of thing.

If it all looks OK, then you can try putting the CMS in to the Report Fault wizard, and then resetting just one task and then once it has sat for 5 or so minutes, collect the data and see what was logged.

I presume this is 1.8.11. If not, upgrading is the first thing you need to do.

1 Like

Hi Alex

Thanks for your advice. It is 1.8.11. I restarted my server and also changed the task in the scheduler to use php-win.exe and not php.exe - one of these things seems to have resolved everything so thank you - data repopulated and graphs back up and running on the displays - it would have been nice to know what it was but never mind - i might have to trawl through my event viewer on my server perhaps…

All the best

1 Like